Remove All Ads from XDA

[Q] External Hard Drive woes...

2 posts
Thanks Meter: 0
By Pickel5857, Junior Member on 4th February 2014, 04:55 AM
Post Reply Email Thread
Not sure if this is the correct place for this, first time posting.

So I'm having a hell of a time getting my Western Digital 2TB external drive to connect to my Nexus 7 2013. I have both Stickmount and Nexus Media Importer installed, and I'm rooted with Cyanogenmod, and I have a working OTG cable.

I know that the Nexus 7 doesn't have enough power to support most external hard drives that use a USB for power. So I bought a 12000mAh external battery with a 5V 2.1A output USB port, and a 4-port (unpowered) USB hub from Radioshack.

Along with those, I had to hunt down a male-to-male standard USB cable in order to connect the female port on the hub to the female port of the OTG cable (using the standard USB-to-micro doesn't work, because for some reason the OTG cable is specifically required to mount USB devices on Android, as you guys probably know).

After finally getting the male-to-male cord today, I tried hooking it up and still no luck. NMI detects the OTG cable but cannot detect the external drive. It works just fine with a flash drive.

Now after looking at the reviews of the USB hub on the site that I linked to, I'm thinking it may be the problem. If you look in the comments you have multiple people stating that this specific hub doesn't play well with many external drives. I haven't had any troubles with it through my PC, but you never know. I've also tried switching between the USB 3.0 cable that came with the drive to a standard USB-to-micro charge/data cable (with no luck), because I've read that NMI doesn't support USB 3.0

Does anyone have any advice or experience with this kind of thing? I'm thinking I may need to find a Y adapter that has one female and two male plugs so I'm not having to go through a potentially-crappy USB hub. But I'm not sure if that'll actually fix the problem or not. From searching around on the web a bit, it seems that connecting this specific drive with the Nexus 7 shouldn't be all that difficult, there's plenty of simple guides out there to demonstrate.

Just to recap, here's my connection process:
- Connect USB hub to external batter (2.1A port), make sure battery is ON
- Connect USB from External Drive to an open port on the hub
- Connect male-to-male USB cable to another port on the hub
- Connect M2M cable to the OTG cable
- Connect OTG cable to Nexus 7 (while on, with 90%+ battery)
- Nothing happens

EDIT - Would have included links to the specific devices, but I'm new to XDA so they won't let me post link yet.
4th February 2014, 03:51 PM |#2  
Junior Member
Thanks Meter: 2
I have a WD 1TB USB3 external drive. The only way I got it to work was by installing Paragon exFAT, NTFS & HFS+ (Available on the Play store), connecting the drive through a normal OTG cable, and rebooting the Nexus WITH the cable connected. Yes, I have to reboot every time with the OTG cable plugged in. I can plug/unplug devices as much as I want, but once the OTG is unplugged, I have to do another reboot; it's annoying, but it is better than nothing. Give this a shot.
Also, what ROM/Kernel are you running?
5th February 2014, 12:08 PM |#3  
DrRuckingFetard's Avatar
Senior Member
Flag Sydney
Thanks Meter: 13
is the drive formatted as NTFS or exFAT? maybe try the ElementalX kernel as it supports both formats for USB OTG and see if that helps?

edit- just remembered that i came across extra files on the Stickmount XDA page a while back that lets Stickmount support NTFS and exFAT drives, if flashing a custom kernel isn't your thing then you could try that..
7th February 2014, 06:25 AM |#4  
OP Junior Member
Thanks Meter: 0
I finally got it to work, and now I just feel foolish.

I just needed to switch two cords. I had the male end of the USB hub plugged into the battery, and then the external drive and male-to-male USB plugged into the hub. The male-to-male cord then went to the OTG and the tablet. This apparently didn't let the data/power through correctly.

I went down to the local computer shop and the guy showed me that I was doing it wrong. Instead of using the hub's male end to hook up to the battery, I needed to use the m2m cord for that. The male end of the hub now connects to the OTG, and it works like a charm. I have to make sure to power up the drive and give it a second before connecting it, but Stickmount detects it right away and I have all my content.

I was pretty sure I'd tried every configuration and that I'd need a Y cable for sure, but I'm glad that's not the case even though I feel like an idiot now, haha.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes