Remove All Ads from XDA

[Q] Data transfer failure ((Too many links) while sending 'system'

18 posts
Thanks Meter: 1
By bokisis, Junior Member on 8th February 2014, 08:27 AM
Post Reply Email Thread
PROBLEM SOLVED! I used another pc, my usb ports were the problem! I recently got my Nexus 7 (2012), wi-fi only , I unlocked it's bootloader, installer TWRP recovery, and rooted it. For all these operations i used the N7 toolkit , because back then, I was a noob. The rooted tablet (4.2.2) worked Perfectly! But, after about 3 months, it's "volume down" button stopped working. I rebooted it, but it went in bootloader, instead of normal system. So I just select "Start" and it was in Safe Mode! OK, my "volume down" didn't work in Safe Mode (and bootloader mode) neither! And every time I reboot it, it goes to bootloader! I thought that it was a software problem () , so I began flashing a new ROM. I didn't want to use the toolkit because everyone says that it's bad . I downloaded AndroidSDK, I re-downloaded the ADB and Fastboot drivers, and I downloaded the newer version of the bootloader (4.23, .img) . Tablet was already in bootloader and I connected it to the PC. In platform-tools folder I ran the "fastboot devices" command, and It was able to see it . So I copied the bootloader img to the same folder, and I ran "fastboot flash bootloader bootloader-grouper-4.23.img" . Then I rebooted it into bootloader again. IT WORKED! But, it didn't solve the "volume down" problem. My rooted 4.2.2 and TWRP were still on the system. Everytime I power off the tablet, and then hold the "Power" button, it goes into bootloader. It was that button issue causing that. Then I decided to take it to the service (same place where I bought iw the unloct) , but I couldn't because if they saked bootloader, non-stock recovery and the root, the wouldn't accept the warranty . I decided to download the latest 4.3 stock android, and stock recovery, flash them, and lock the bootloader. I downloaded 4.3 stock from google's official site, (nakasi-jwr66y) and I used the flash-all.bat command that came with it.

.bat command looks like this:

fastboot oem unlock
fastboot erase boot
fastboot erase cache
fastboot erase recovery
fastboot erase system
fastboot erase userdata
fastboot flash bootloader bootloader-grouper-4.23.img
fastboot reboot-bootloader
ping -n 10 >nul
fastboot -w update

echo Press any key to exit...
pause >nul

I ran it. It successfully did the oem unlock (it was already unlocked) , all the erase commands, and flash bootloader command. But it was stuck on

"fastboot -w update" . It stays steady for about 30secs , and than it says

"sending 'system' (x-kb)"

After some time it just says Data transfer failure(too manly links) ...

I tried the same process billion more times, but same error :/

I tried

-Re-downloading and installing the drivers
-Changing the usb ports, and microUSB cables,
-Restarting the pc (of course)
-Re-downloading the nakasi-jwr66y
-Downloading the twrp recovery (it successfully flashes it)
-Re-downloading the whole SDK

But it DOESN'T WORK? What should I do? Is the volume-down issue hardware or software ?

Sorry for my bad English :////////

P.S. What is the difference between "fastboot flashall" and "fastboot update" ?
The Following User Says Thank You to bokisis For This Useful Post: [ View ] Gift bokisis Ad-Free
Post Reply Subscribe to Thread


Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes