Remove All Ads from XDA
Honor 9 Lite

Wingray - Internal Storage has been wiped, and I'm out of my depth.

7 posts
Thanks Meter: 0
By competentfake, Junior Member on 5th February 2014, 04:47 AM
Post Reply Email Thread
My friend gave me his bricked Xoom, which I accepted as a challenge, because I've been rooting and flashing my phones for years, but after 10+ hours of searching in the last couple weeks, I have been unable to locate coherent information on how to un-brick a Xoom that has had its internal storage wiped. My friend was trying to do a thorough wipe, and he succeeded in that, if nothing else.

My first obstacle was finding a driver, because Motorola Device Manager wants nothing to do with the Xoom, and whenever I finally found a link to a driver, it was at, and there apparently is no such domain, because every link takes me straight to, where all that's waiting for me is the bloody Moto Device Manager.

The only post I found that seemed like it was aiming at where I want to get is at, but I ran into problems that weren't foreseen by the author, and I haven't been able to find anything pertinent that doesn't direct me to again.

The Xoom has TWRP v. edition) for a recovery; and I'm aware that there is a 3.3 version, but I'm nervous about flashing a recovery update when there is no OS on the tablet. It was running EOS 4.2.2 I think, before the bricking.

According to the guide I found, I put TWRP into adb sideload and was able to get my PC to communicate by installing a universal adb driver from, so in my system Device Manager, the Xoom is listed as a GOOGLE GALAXY NEXUS ADB INTERFACE.

When TWRP is in adb sideload, I can interface with the Xoom via cmd.exe, but when I try to push a ROM, I keep getting an error on TWRP:
file_getprop:failed to stat "/system/build.prop" no such file or directory
...whatever that means. Another thing that kind of worries me is that when I type adb devices, it shows my device as 1234567890ABCDEF, which doesn't seem right.

I have yet to try fastboot, because I don't know what .img files I need to flash, and I don't think blind flashing is going to make things any better.

I think I have all the pieces, SDK and JDK are installed and updated, and I have the stock rom ( I reckon if I can get the stock 3.x OS running, I'll have a jumping-off point, and be good to go; the process from there is well-documented.

Can anyone give me a nudge in the right direction, please?

5th February 2014, 10:23 PM |#2  
Senior Member
Thanks Meter: 26
Status 7 errors
Those are usually caused by either a not-so-compatible recovery image. Some TWRP versions have issues with certain ROMs. I had this happen to me with my Asus TF300, ended up trying a few different TWRP versions before I found one that worked right.

The other cause is an invalid ROM image, if you open the file on your PC, does it look ok, did you check its MD5sum???

Were you able to wipe the Xoom from TWRP without error???

7th February 2014, 04:46 PM |#3  
OP Junior Member
Thanks Meter: 0
When I got it, it had been wiped completely, so I presume that twrp wiped okay.

Not sure about the MD5sum, just that twrp didn't find one during the adb installation. Do you think flashing cwm might help?.
9th February 2014, 02:06 AM |#4  
OP Junior Member
Thanks Meter: 0
I got it worked out, opened up the stock image and fastboot flashed the individual .img files, and it booted right up. Thanks!
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes