Remove All Ads from XDA

FIX: failed to mount /efs error message

9 posts
Thanks Meter: 0
By daggerNC, Junior Member on 9th February 2014, 06:37 PM
Post Reply Email Thread
There are a number of threads throughout xda-developers, but I had a very long journey to find a fix that worked with my T-Mobile T989 Galaxy S2 phone. In a nutshell, sometime over the last week I somehow corrupted my /efs directory/folder enough so that it wouldn't mount. The symptoms I started to have was that I couldn't load any custom ROM without it going into a boot loop eventually. Even the backups that I saved would not work! I was able to use Odin to factory reset my phone back to 2.3.6 gingerbread, and it would run, but if I tried to load any ROM including going thru a Kies factory update, it would fail. (Note I still had a valid IMEI number displayed) Then I saw the failed to mount /efs error on the factory recovery window. So after many attempts to find and try a specific fix for my T989, I came across this thread in the Skyrocket phone section. This guy named icenight89 came up with a method to fix their phones, with a note that it will work on T989's as well.

The fix for me that worked was for me to factory reset to 2.3.6 via Odin. Then load in CWM recovery and then Super-SU to root the phone. Then download a file on icenight89's thread called and upload it to your phone. (Nandroid backup first) then boot into CWM recovery and install this .zip file, and reboot, and voila the efs partition is mountable again!! Here is the link to icenight89's thread and in there are the file links:

Hope this can help shortcut the fix for our phones for someone else who runs into this.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes