Remove All Ads from XDA

Galaxy S III Boot Animation Sound Delay

4 posts
Thanks Meter: 0
By BetaJ, Junior Member on 7th February 2014, 06:37 PM
Post Reply Email Thread
First off, let me thank you for any help that I might get resolving this issue. Second, I have searched all over xda and cannot find this question about this particular phone, let alone an answer. Please be kind on me, I am not a complete noob, but I still have some learning to do as well. And forgive me if this is posted in the wrong place.

I have an At&t Samsung Galaxy S III running 4.1.1. It is rooted with custom recovery (TWRP) and stock rom. I have flashed, created a custom file, placed it in system/media and set the permissions with root explorer. The animation is working fine. I have also downloaded a sound.oog file that goes along with the boot animation. I renamed the sound.oog to PowerOn.oog, placed it in system/media/audio/ui, and set the permissions using root explorer and the sound plays just fine except there is a 3-4 second delay before the sound starts playing after the boot animation starts. This is driving me crazy. I know there was a similar issue with the Droid RAZR here: . However, I have tried changing the desc.txt and that unfortunately didn't fix the problem on my phone. I cannot find any answer that has solved this issue. Please, any help would be greatly appreciated.

Also, I have the same issue with a Sprint Galaxy Note II running 4.3. stock rom with TWRP recover. I really don't want to flash a custom rom but I will if you think it will fix this frustrating problem. Thank you
10th February 2014, 10:08 AM |#2  
OP Junior Member
Thanks Meter: 0
I've done some more digging and found here: that the audio driver configuration and policy implementation is located in /etc/tinyucm.conf . Based on this information and my own observation of the boot process, I think the sound delay is just a natural function of the boot process itself as the drivers take a few seconds to load after the boot animation starts. I could be way wrong. If anyone has any information about driver load priority, or anything that could help me solve this, I would be grateful for your help. I am wondering if there is any way to fix this by modifying the tinyucm.conf file? Probably not for what I am attempting, but if it can be done I would really like to know. I'm going to try to pull the file and see if I can make any sense of it. For now I have added a custom splash screen before the boot animation and sound starts. Since I am using android 4.1, I modified the desc.txt file to allow the boot animation to play until it finishes so it wouldn't get interrupted by the completion of the boot process. It is a lazy work around, but it works for now. As always, thanks for your help.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes