Remove All Ads from XDA
Honor 9 Lite

[Q] Bricked T-mobile ZTE 768 concord

1 posts
Thanks Meter: 0
By brickedconcord, Junior Member on 10th February 2014, 11:41 PM
Post Reply Email Thread
Hello all,

I have been searching all day trying to find an answer to this issue but so far have only really found information on the ZTE blade...

Today my ZTE concord (v768) randomly turned off. When i tried to boot it back up, i got stuck at the green android boot screen. I tried taking the battery out and tried to boot with the volume up and power keys, or the volume down and power keys, to try to enter recovery mode with no avail.

I have also tried the guide found here- and the program wouldnt recognize the device when it was plugged into the computer (stuck at the green android logo).

I also tried installing adb but could not get adb to locate the device.

when i plug the phone in to charge it shows an empty battery container with a circle inscribed in it composed of 6 lines (very similar to this logo,, but with only 6 lines instead of 12.

Is there anything left to try here? Or is this a hardware issue that no amount of fiddling with software can correct?

Thank you for all of your help, and if you need any more info please let me know!
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes