Remove All Ads from XDA

Help! Tablet Wont charge Usbport may be malfuntioned

7 posts
Thanks Meter: 0
By menk1313, Junior Member on 9th February 2014, 01:57 PM
Post Reply Email Thread
Ok so if anyone can help it would be very much appreciated . I bought a Sony Xperia Z WiFi only tablet about 6 months back and only 1 month into having the device it stopped charging and now I can no longer turn it on. I don't know if its the system itself or the minibus port honestly. Ive tried several things but nothing seems to work . Details- Device suddenly shut down while there was plenty of power left . I unlocked bootloader and tried to flash custom rom but couldn't figure out a small part at the end right before restarting but was able to flash a stock rom straight from Sonys FlastTool . I need this device to run my Sonnos App cause I just bought the whole kitten kabudle and my Nokia Lumia 2520 runs Windows RT which unfortunately has yet to develop an app for Sonnos . Any help would be much appreciated!
12th February 2014, 11:08 PM |#2  
Senior Member
Flag Reading
Thanks Meter: 20
You may still be able to charge it via the dock connector if you can get hold of one but it won't be as convenient as being able to use a micro USB charger. Personally I'd take it back as it isn't a year old yet and see what Sony say.

Sent from my SGP321 using Tapatalk
13th February 2014, 09:19 PM |#3  
Senior Member
Thanks Meter: 105
Yeah contact Sony they are really good with repairs

Sent from my C6506 using Tapatalk
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes