Remove All Ads from XDA
Honor 9 Lite

[Q] Cant restore stock backups with CWM or TWRP

4 posts
Thanks Meter: 0
By Ashlander80, Junior Member on 14th February 2014, 01:02 PM
Post Reply Email Thread
So im still pretty new to this, but im pretty technical so I pick up on this stuff pretty quick. When I first started getting into this stuff I was using CWM as I saw it used most often around the forums. After getting root and unlocking I backed up my stock rom, and then tried to restore it just to test, and it failed. I tried a few times, with different settings, and it failed everytime, so I pretty much had no choice but to go to custom roms at this point. After switching to TWRP 2.6.3, and messing around with a few CM7.2 and CM9 roms, I decided to flash the 4.5.141 sbf (came from 4.5.145), which bricked me untill i flashed the pudding file again, then flashed a 4.5.145 update fruitcake, so i was back to where I was. Backed up the stock rom again with TWRP, wiped everything just in case that was the problem before, and it still failed when I attempted to restore. Again tried different settings, restoring from the SD card, from the internal, mounted and unmounted partitions. Nothing. I flashed CM9, backed up, and it restored flawlessly. Reflashed 4.5.141, pudding, and 4.5.145 update again, repeated the backup and restore. Fail.

All partitions restore except the system partition. No errors are given in the dialog box. The last line of text is "Restoring system..." However, looking through the log, I find this at the bottom;
==> tar_extract_regfile(t=0x139110, realname="/system//etc/spellchecker/pt_BR.dic")
  ==> extracting: /system//etc/spellchecker/pt_BR.dic (file size 4581228 bytes)
FAILED RESTORE OF FILE i: /system//etc/spellchecker/pt_BR.dic
E:Unable to extract tar archive '/sdcard/TWRP/BACKUPS/TA20708E1R/4.5.145_Stock/'
I:extractTarFork() process ended with ERROR=255
Whats the problem here? I flashed CM9 and it backed up and restored without a flaw. Why is it just the stock roms that are failing me?
17th February 2014, 11:57 AM |#2  
OP Junior Member
Thanks Meter: 0

No ideas from anybody?
17th February 2014, 05:34 PM |#3  
Senior Member
Flag Córdoba
Thanks Meter: 363
Iirc, thete was an issue oreventing the correct decompression of system. On the international fruitcake thread this is discussed.

I had that trouble also, but since the stick rom is a piece of crap, just deleted the backup and installed other roms hehe

Enviado desde mi MB860 usando Tapatalk 2
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes