Remove All Ads from XDA
Thread Deleted Email Thread
Prev Previous Post   Next Post Next
About three days ago, in the middle of the day, I tried to unlock my Verizon S3 using the power button, but it remained on a black screen. I pulled the battery, replaced it, and tried again. It came on.

Over the next day, it performed this behavior three more times; this time, however, the "black screen, unresponsive" happened while I was using the device (e.g., reading reddit in Reddit Sync when the screen darkens and the device becomes unresponsive and silent). The first two times, a battery pull let me restart the device.

The third time, however, nothing would restart the S3. A different, fully charged (and tested working) S3 battery would not start it. Plugging it into multiple chargers and multiple computers--both with and without a battery--would not start it. Plugging it into a PC fails to install drivers, and the S3 is identified as a "QHSUSB_DLOAD" device by Windows.

Plugging it in sans battery will sometimes briefly illuminate the red charging light, but it eventually turns off on its own, or goes off if I hold the Power button or put a battery in. I cannot access Recovery or Download Mode using the standard button combinations; there is no vibration, no flash on the screen, no change on the LED, and no sound. No input I give the phone appears to have any effect at all.


The phone was running an unlocked, rooted version of 4.1.2, but had no other modifications, and had not had any major system changes in the months prior to this starting. I haven't recently messed with the bootloader, taken the 4.3 update, unrooted, rerooted, or anything else aside from letting apps update naturally and using the phone as always (reading reddit, using Hangouts to chat, listening to music with PowerAmp).

I read about the "Sudden Death Syndrome," but that supposedly applies only to International S3s. I read about hardbricking via screwing up your bootloader or triggering the eFUSE protections, but since I wasn't messing around with any of that for months now and also since I did not take the 4.3 update, I suspect it wasn't the cause.

Reps at the store weren't able to resuscitate the device, but told me I was ineligible for warranty service (I have extended) due to a hairline fracture on the case an inch below the power button (this crack has been there for months).

The device hasn't suffered any water damage or recent drops and was otherwise fully functional before the first blackscreen a few days back. I can't afford an Insurance swap right now, so self-repair is my only hope of having a working phone before my next paycheck hits in a few weeks
Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes