Remove All Ads from XDA
Honor 9 Lite

[Q] Edited SystemUI.apk simply not working.

2 posts
Thanks Meter: 0
By intothehallows, Junior Member on 16th February 2014, 09:12 AM
Post Reply Email Thread

I have a devastatingly annoying problem on my hands, involving my SystemUI.apk (go figure).

You see, I've been trying to edit my status bar, and make it semi-transparent.

First, I followed this guide:

And then this one:

But neither seemed to work. All I get is a message telling me that SystemUI.apk has stopped working (I have tried rebooting, it doesn't work.)

Now the process I went through to edit the .apk file was, of course:

1. I extracted /system (and all its apks) with adb

2. I installed the framework of both framework-res.apk and SystemUI.apk with apktool using:

apktool if framework-res.apk

apktool if SystemUI.apk
2. I decompiled the apk with apktool

apktool d SystemUI.apk SystemUI_new
3. I edited the status_bar.xml file with Notepad++

4. I recompiled with, again, apktool.

5. I went and made a copy of the original apk, and copied the altered files from the edited apk to the copied one.

6. To be safe, I got drag2sign (the bat file, yes) and signed the apk.

7. I copied the new apk onto my phone, and put it in /system/app/ to replace the original .apk

8. After rebooting my phone, my status bar was gone.

Just to be sure, I went ahead and copied back the original SystemUI.apk back into system/app just to check if I was putting it in the wrong place, but after rebooting once more it worked fine.

I have a niggling suspicion that it was something either to do with the permissions that are set on my edited apk (--- r-x rwx, which I have no idea how to change) or the fact that I'm meant to edit something in the framework-res.apk or twframework-res.apk, which both remain at a plain deodex as of now. I have attached the edited apk, just so if anyone wants to take a thorough look at the one line I changed to tell me what I have done wrong, they can go right on ahead.

The only reason I am being so unnaturally detailed in this question is I have quite honestly had it with this stupid SystemUI.apk, and am desperate for help. Please, if you have anymore questions you have to ask about what I have/haven't done, please, ask away. If you have a solution, feel free to berate my stupidity. If there is a thread on XDA which I overlooked, please shove it in my face. Anything to figure out what the hell I am doing wrong.

Attached Files
File Type: apk SystemUI.apk - [Click for QR Code] (272.5 KB, 89 views)
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes