Remove All Ads from XDA
Honor View 10

[Q] Paradox of damaged partitions

18 posts
Thanks Meter: 1
By kriistofor, Junior Member on 16th February 2014, 05:40 PM
Post Reply Email Thread
Well, hello. Not new here, but quite new in posting things, was always just reading what these guys are doing and followed their instructions. result was always being able to flash whatever on a selected device. But today i'm coming with a stupid problem that i hope somebody would help me solve.

2 days ago (and i will be full of details here) di flashed ARHD51.0 on my Htc One. everything went well (as usual with those roms) but i wanted to format my whole phone (i had like 5gbs of backups that i could not find (4 months i was xda-ing and googleing solutions for removing invisible backups that cwm made. and then i read this
as you well know, this is a member of trust on this site so i decided to follow those instructions and that backfired on me i must say. what happened next was that my phone was in a bootloop, recovery was dameged and adb (and still) could not read my device, fastboot would on the otherside.

I managed to flash new cwm (philz touch via fastboot and it worked. but in cwm messages are following (will copy just some of the lines because you will understand the problem)
failed to mount /dev/block/mmcblk0p39 on data ext4 (file exists)
failed to mount /data
failed to mount /cache
then something like failed to install /tmp/ (that message was shown when i was trying to install stock rom)

and i sideloaded stock (fail), arhd (goes to 30%, freezes on writing data&system)
when exiting cwm, it asks me to reinstall the root because it is missing (even when i install it manually via usb otg or sideload and it says done, still root is non existant.

baseline is this: i formated the sd card, and tried to do as much as i could with all the logical things, my partitions are messed up and i'm missing boot.img and system files, unable to mount data/cache/sd card. Now i can do only so much to ask you. I can try to relock the bootloader and use the ruu (but i am s-on) i can try to send boot.img or something (but how when adb push is not working, "device not found") i can format the partitions but do not know how to format them from cmd or cwm.

currently i'm downloading stock deodexed and odexed stock roms and ruu. i already have su, philz touch advanced (planning to try to flash that only because of more options than standard philz cwm) and otg ready cable to use it if there is no help for adb push.

Anybody, please help because i will tryto fix this, but i'm afraid that if i mess the order of things that needs to be done, i could brick this totally, and in this area of damaged partitions i have no exact experiance.

Any help appreciated, and can be (gladly) rewarded on demand

sorry for funky and somewhere incorrect gramatic structure, if something is unclear about it, feel free to ask
16th February 2014, 06:41 PM |#2  
nkk71's Avatar
Recognized Developer / Retired Recognized Contributor - R.I.P
Flag Beirut
Thanks Meter: 7,567
Donate to Me
Originally Posted by kriistofor

failed to mount /dev/block/mmcblk0p39 on data ext4 (file exists)


post a "fastboot getvar all" (leave the first 2 characters of serial number, IMEI, and MEID, and "xxxx"-out the rest)
and maybe a screenshot of bootloader

you either have a Sprint/Verizon HTC and/or the wrong recovery!!

so stop!!!! and post above needed information
17th February 2014, 12:31 AM |#3  
OP Junior Member
Thanks Meter: 1
Originally Posted by nkk71


post a "fastboot getvar all" (leave the first 2 characters of serial number, IMEI, and MEID, and "xxxx"-out the rest)
and maybe a screenshot of bootloader

you either have a Sprint/Verizon HTC and/or the wrong recovery!!

so stop!!!! and post above needed information

sorry,sorry i sounded a bit overexcited and impulsive.
well, i have international htc, but the cwm (even though i downloaded the M7(gsm) version was the biggest problem for the phone (based on the name of the cwm it does not sound logical to me). Also, i used non touch and it also was useless but i managed to solve this after two whole days of mind****ng myself and this phone.

relock bootloader (without this you can try anything as i did but it will fail if the problem is the same)
unlock bootloader
install twrp (for some reason after this cwm, no other cwm was able to format partitions or anything)
format data, or full wipe option
stock rom (installed deodexed 4.4.2)
root if want

problem was gone in 4 minutes, it booted faster than any other thing i've put on this phone (like in 2 minutes fully booted into welcome screen).
now it is running arhd 51.0, elementalX and is alive and well.

solution is probably effective wih all of those problems with corrupted or badly formated internal sd on One but i will say that people here are giving solutions that are logical and are working for others with similar problems. this one is for those who have tried all the things with reflashing recovery, rom, with bad adb experiance because of formatted card and are unable to sideload anything.

thank you for help because if I haven't succeded with this leap of faith i would more likely f*c? something up by myself. and thanks for reply, expected no one would give any
Post Reply Subscribe to Thread

bootloop, damaged partitions, formatted /sdcard, htc one, softbricked

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes