Remove All Ads from XDA

[Q] Wifi Problems [Solved]

16 posts
Thanks Meter: 10
By SomeGuy4, Junior Member on 27th January 2014, 01:39 AM
Post Reply Email Thread
Phone: Samsung S4 mini SGH-I257m (Canada Rogers)
Android 4.2.2 I257MVLUAMK5

I used an app called "Wifi Pass Recovery & Backup" and it killed my wifi. It tries to turn on and fails. I could redo my phone completely but I would rather fix it.

I have tried many things:

I made a backup with the app before doing anything and restoring that did nothing. Using the in app "reset wifi settings" button also did nothing but remove my saved networks.

Using ES File Explorer I have looked at the /system/bin/wps_supplicant, /data/misc/wifi/wps_supplicant.conf, /system/etc/wifi/wps_supplicant.conf. Played around with permissions, owner and checked MD5 with backed up versions. One thing I noticed was that the permissions seemed to reset when I would reboot.....

I used logcat and couldn't gain any ground there.

Some post I saw said something about replacing /system/bin/wps_supplicant with the one from the stock firmware, but i couldn't figure out how to find the files in the firmware I downloaded. I did find a factory image from google and was able to extract the files I was looking for, but they didn't work either. No surprise there.

I would love some help this as you guys are the experts!

1st February 2014, 06:29 PM |#2  
OP Junior Member
Thanks Meter: 10
Are there any other files that have to do with wifi? They might be worth checking out.
17th February 2014, 11:03 PM |#3  
OP Junior Member
Thanks Meter: 10
Ok....So, I was able to fix the problem by going back to the stock ROM. Not what I was wanting but whatever.

In an effort to try to figure out what happened, I cross-checked the stock files with the the ones I had before.

- the MD5 checksum of /system/bin/wpa_supplicant was identical
- /system/etc/wifi/wps_supplicant.conf was identical
- /data/misc/wifi/wps_supplicant.conf had a difference with config_methods. Stock was 'physical_display', old was 'physical_display virtual_push_button keypad'

So as far as I can tell.....that one entry was the problem.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes