Remove All Ads from XDA
Honor View 10

Himedia Q2 Brick

1 posts
Thanks Meter: 0
By Scott1975, Junior Member on 18th February 2014, 09:17 AM
Post Reply Email Thread
After setting WIFI on in settings my Hi media Q2 it rebooted and got stuck in a boot loop. I tried flashing with the firmware from the site ( this seemed to go through fine the first time but the boot loop was still there.

So I tried older firmware in the hope that it would work, using USB1, USB2 and SDCard but now it fails the recovery every time (red x dead android).

Anyway of resetting and getting the box working again?

I have owned the box for six months and the warranty was only valid for three... so that is out of the equation.

I emailed the Himedia support email (English and google translated Mandarin) but have received no response.... so help me XDA you are my only hope...

thanks in advance

Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes