Remove All Ads from XDA
Thread Deleted Email Thread
Prev Previous Post   Next Post Next
I got a secondhand Xperia T a couple of months ago. The phone was originally bought in 2012 in Ireland. The phone is now unlocked to any network.

Friday two weeks ago the phone stoped working. What happened was, the battery was on around 15%. By the time i got round to charging it it had gone flat. After plugging it into the wall charger for around half hour the solid red light was on indicating charging but the phone wouldnt turn on. I left it for a while but it was still the same. I notcied that when i pressed the unlock button the screen would slightly light up but no picture. the phone could recieve texts and calls but i couldnt see anything. I took it to my nearest phone specialist. He tried re installing the software but had no luck. He said it was bricked. I then gave it to my uncle who is usually nifty with these sorts of things. He also came back and said it was bricked. I then did some reading of my own and came across the advise to re install soft ware through pc companion. I did that and it said it was successful but the phone was still the same.

Last night i was following the repair thread on here (cant find link right now)

The problem i had was i didnt know witch stock ftf file i need to download or where to download from.

Can someone give me a link to an irish stock ftf and give me a quick run throuhg of how to fix

P.s. This is whats happening with the phone now:

When plugged into the wall charger I get a green light, that goes out after a few seconds then the changes to red and proceeds to charg normally.

Phone still vibrates, and receives calls.

When the on button and + or - vol are pressed it vibrates like its supposed to but then nothing happens
Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes