Remove All Ads from XDA

Updated to stock touchwiz 4.3, phone freeze when make call

38 posts
Thanks Meter: 5
By kawaiichi, Member on 5th February 2014, 07:58 PM
Post Reply Email Thread
I was using CarbonROM based on JB 4.3.1 but was getting fed up with not being able to connect with families oversea through VOIP such as skype, viber, etc... because the mic doesn't work with voip apps in AOSP Roms. So I decided to go back to stock and full flash samsung's 4.3 stock rom via Odin 3.9; the rom was 2.24GB extracted so I'm almost certain and well aware that it's the bloated tmo samsung tw version.

About device show android version 4.3, baseband M919UVUEMK2, and I can get LTE signal fine but cannot toggle wifi on. And when I go to place a phone call the entire UI freeze and won't respond, then come the "Process isn't responding" dialog box. Except for wifi and phone call everything else seems to work, but I haven't tested extensively yet nor are they important to me.

From here I went about installing latest CWM recovery and SU, and I was able to install OmniROM and CM11 nightlies. But the phone UI freezing problem still persist even with those custom roms.

At this point I have an inkling it has something to do with the new MK2 modem. I noticed that when installing the stock fw it had modem.bin and NON-HLOS.bin entries in Odin. I read through other threads and some mention about not installing NON-HLOS.bin file, but it was included in the stock fw so I don't know why it would misbehave (if it's the culprit)

At this point I am out of options. Someone with knowledge and experience with this please give helps or suggestions. Thank you!
5th February 2014, 09:59 PM |#2  
baseballfanz's Avatar
Senior Member
Flag Sugar Land TX
Thanks Meter: 1,723
If you flashed via Odin, you had no choice with the non _hlos.bin. That's only for peoples sticking with mdl bootloader but flash 4.3 ROM.
Have you tried a factory reset after updating to 4.3

☞ Sent from here☜
7th February 2014, 06:58 AM |#3  
OP Member
Thanks Meter: 5
I did a factory reset in TW and it still freeze. I can open the dialer app, punch in a number or choose from contact list, but as soon as I hit Dial the whole phone freeze. The connection is made because I test dialed my home phone # and it rang, just that I could not get the phone to talk. No dial sound from the phone, screen it black; I can see status bar but it won't respond to my touch. When I pick up the home phone and tried to make a conversation there's no sound coming out of the S4, and even if I yell real loud into the mic no voice is carried over to the home phone.

I tried installing latest Omni rom 4.4.2 kitkat nightly, did a factory reset after letting phone sit still at home screen for 5 mins after installation, still can't get the phone app to do its job at all.

Edit: forgot to mention that the phone is unlocked and I'm using Straight Talk AT&T LTE sim. LTE works fine, just no calling due to this update problem here.
9th February 2014, 12:12 AM |#4  
OP Member
Thanks Meter: 5
nvm I fixed it by reflashing a file Modem_UVUAMDL.tar.md5 until it turns back to MDL baseband, then flashed modem.bin only and it everything works again.
18th February 2014, 06:00 PM |#5  
Junior Member
Thanks Meter: 0
Originally Posted by kawaiichi

nvm I fixed it by reflashing a file Modem_UVUAMDL.tar.md5 until it turns back to MDL baseband, then flashed modem.bin only and it everything works again.

i'm having the same issue, I was to download the modem_UVUAMDL.tar.md5 but it did not include the modem.bin. is it safe to use any version of the modem.bin file I find here?
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes