Remove All Ads from XDA

Tasker profile to change input to Swiftkey on reboot

1 posts
Thanks Meter: 0
By Choncie, Junior Member on 19th February 2014, 02:19 AM
Post Reply Email Thread
I use SwiftKey ($) as my standard keyboard on the S3 since the built in keyboard mostly stinks. But the one problem is the input method reverts to the Samsung keyboard when the device reboots. I searched around & couldn't find exactly what I was after, so thought I'd post my solution here to pay it forward.

Rooted phone (using SuperSU free)
Tasker ($)
Secure Settings (free)
Busybox (free)

0. before starting, install Secure Settings, go to system+ tab, click to enable. It will help you get busybox if not installed. Once installed, again go to system+ tab and get it Enabled.
1. create a tasker "Event" profile
2. Event type is System>Device Boot. There are no options here, tap to go back
3. New task, give it a name ("Change Input Method" is good)
4. + to create an action, then Task>Wait. I put 40 seconds here. This is the delay after reboot before tasker goes & changes the method. It takes a while for my phone to be ready to roll after a reboot. YMMV. Tap top left to go back.
5. Now + to add another action and select plugin
6. Secure Settings, pencil to modify configuration
7. System+ Actions>Input Method, tap to select the input method (Swiftkey for me but this could be anything you want).
8. Click the save icon.

That's it. Try rebooting and see if the input method is changed to Swiftkey after the reboot. Works for me! Enjoy!
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes