Remove All Ads from XDA

[Q] Wi-Fi Just Decided To Stop Working (Switches Off After 30 Seconds Or So) CM7

128 posts
Thanks Meter: 1
By swinster, Senior Member on 12th February 2014, 07:52 PM
Post Reply Email Thread
Hi All,

I am still lumbering on with an old HTC Desire running CM 7.07282011-Nightly and have had no real issues up until a couple of days ago.

Whilst in France (not that that make a lot of difference) the Wi-Fi access stopped working and the phone stopped being able to see any Wi-Fi networks. Basically, it switches itself off after around 30 seconds and cannot pick up any networks. In addiiton, the WiFi MAC address shows as unavailable although teathering via a WiFi hotspot works fine. I was switch between teather and normal Wi-Fi when the problem occurred.

If I go into Settings --> Wireless and Networks -->WiFi setting, then switch on the Wi-Fi, I get the "Turning on" message but then a Sorry warning saying "Application Settings (in process com.andriod.settings is not responding" and I can either "force a close" or "wait". If I wait, the Wi-Fi will simply switches itself off after about 30 seconds.

I did read in another post that this might be to do with the Wi-Fi sleep status but I tried all 3 options (from the menu in the Wi-Fi setting page) but that didn't do anything.

The issue appears to be that that phone has lost the Wi-Fi adaptors MAC address (says unavailable). However, I can still use Wireless Tethering and connect to to the phones WiFi hotspot. I think something has go screwy with the Wi-Fi tethering and Wi-Fi access (as I was switching between both when on my travels), but I need some help in trying to fix it.

Any Help Welcome

12th February 2014, 08:19 PM |#2  
OP Senior Member
Thanks Meter: 1
I tried updating to cm-7-20130301-NIGHTLY-bravo (whuch was the last release version), but still no joy.

Any help welcome
22nd February 2014, 07:35 PM |#3  
OP Senior Member
Thanks Meter: 1
Well, after trying pretty much everything, I had to run a factory reset on the phone. Finally, my Wi-Fi is working again. Of course I now have the ball aching job of setting the phone up and re-installing all my apps again. Google restore is pretty rubbish

Looks like there must have been a config setting that got screwed somewhere. I did take a backup of the ROM and if anyone knows where this might be resolved, I wouldn't mind restoring.
Post Reply Subscribe to Thread


Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes