Remove All Ads from XDA
Honor View 10

[Q] CM 11 data connection troubleshooting (RESOLVED)

36 posts
Thanks Meter: 22
By Arson Smith, Member on 5th March 2014, 09:33 PM
Post Reply Email Thread
I have been running CM 11 Nightly builds, and everything has been working out pretty good, until just a day or so ago.

Now suddenly I find that I never get a data connection (3G, etc) - works fine on Wi-Fi of course though.

Using the FC09 multiboot, I am able to prove that it is not an issue with my phone hardware or my Sprint account.

FC09 has data connection and everything is cool, until I reboot into latest CM 11 (right now = cm-11-20140305-NIGHTLY).

(Since I don't have enough posts yet to ask this in the development thread, I thought I'd try here and see if I had any luck.)

In trying to research this, I see some talk of "APN settings" - but I cannot for the life of me figure out how to access those settings to change them

(Some advice said to speak "Open APN" into the voice dialer? But that is not doing anything for me...)

I guess I am also curious if this is happening to anyone else using CM 11 Nightly builds?

Again, the data connection works when I "multiboot" FC09, but cannot get it to work on latest CM 11 Nightly.

Any help or suggestions on things to check/tweak are highly appreciated - thank you in advance.
6th March 2014, 10:21 AM |#2  
Junior Member
Thanks Meter: 0
Yap... that append to me also, i'm on a GT-I9000 with the same NIGHTLY version. That must be a rom problem, because with the previous version, worked ok.
6th March 2014, 07:10 PM |#3  
OP Member
Thanks Meter: 22
Getting closer to a solution (?)
Same problem (currently running cm-11-20140306-NIGHTLY)

I did finally figure out how to acces the "Open APNs" screen.

My mistake was trying to say "Open APN" from the regular phone dialer, which just threw the voice command to Google.

Then it suddenly clicked - they meant the separate application that is named "Voice Dialer".

(thought I would post that in case it saves anybody else some headache)

So then I found this buzzmobile link that lists "Sprint APN Settings for Android (US)"

I thought I was just about to get this all taken care of... BUT, now here is the problem:

No matter how many times I have tried to enter and re-enter the APN settings, they are not being saved.

I don't know if anyone has any experience with this issue, but if you have any advice, I am all ears - thank you.
6th March 2014, 07:37 PM |#4  
Thanks Meter: 14
Originally Posted by Arson Smith

No matter how many times I have tried to enter and re-enter the APN settings, they are not being saved.

Boot into the temporary FC09 installation and try the "##DATA#" dialer code. If thats not the right code then its gotta be another one that allows you to access these settings. You may also need your MSL.
The Following User Says Thank You to Mr_You For This Useful Post: [ View ] Gift Mr_You Ad-Free
7th March 2014, 02:29 AM |#5  
OP Member
Thanks Meter: 22
My journey
OK, so I'm back in business again, and thought I would share...

1) Booted into the "multiboot" FC09 and installed 'APN Backup & Restore' app

2) Made a backup .xml file from there

3) Rebooted back into CM11

4) Installed 'APN Backup & Restore' app - BUT - could not restore the APN .xml file yet - special steps needed to get this to work with KitKat

5) Installed 'ES File Explorer File Manager' app

6) Followed instructions in this article to change 'APN Backup & Restore' to a system app:

How To Install Any App As A System App On Android [Guide]

NOTE FOR KITKAT: where it says to move the app to /system/app, you actually have to move it to /system/priv-app

7) After following that, I opened up 'APN Backup & Restore' app, but I was confused that it still said "Unfortunately APNs cannot be restored or deleted on this device because Android 4.0+ does not allow 3rd party apps to Write APN Settings."

8) Then I realized that I still needed to go into the settings of the app and click 'Disable ICS Check'

9) Then the app was recognized as a system app and I could do a restore from my .xml file

[EDIT: attaching a .zip of the .xml file that I snagged from booting into FC09]
Attached Files
File Type: zip - [Click for QR Code] (8.2 KB, 38 views)
The Following 3 Users Say Thank You to Arson Smith For This Useful Post: [ View ] Gift Arson Smith Ad-Free
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes