Remove All Ads from XDA
Honor 9 Lite
Thread Deleted Email Thread
Prev Previous Post   Next Post Next
Hi, I have an iPhone 5 clone which I cannot connect to my pc. (Win 7 64/32 bit) When I plugged it in, it detects as "Unknown Device" in USB controllers category in Device Manager. I've tried a bunch of MTK 65xx drivers, ADB drivers, Install from disk (.inf file), even tried Pda.Net but still can't install the usb drivers.

I've also tried to power it off then press Volume + then plugged it. (SD card removed, battery cannot remove because it's soldered) It detects as MTK USB Port but it never detects as MTK 65xx Preloader as to what I've searched.

I am so frustrated and I really really want to connect this to my pc so I can start flashing on it.
I hope you can help me with this guys.

model: MT6517
board: sanstar15_2006_p5_gb2
manufacturer: ALPS
CPU: ARM Cortex-A9
RAM: 233 MB
hardware: MT6575
Android Version: 4.1.2 (but I can tell it's Gingerbread)
Kernel Arch: armv71
Kernel Version:
Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes