Remove All Ads from XDA

Can't mount internal SD Card after installing Albinoman887's 1/12/14 KitKat Rom

26 posts
Thanks Meter: 3
By max13b2, Junior Member on 16th January 2014, 11:04 PM
Post Reply Email Thread
So I have installed several versions of this ROM since it began, however when I upgraded to 1-12-14, all went well except my internal SDcard will not be recognized. This means I can't use the camera or Titanium Backup, etc. However, I can see and use the external sd card w/o any issue. Upon every boot I get the icon saying that I need to format SDcard0, but it never completes, only soft reboots and the icon is gone until the next full reboot. I flashbooted boot.img twice after doing a FULL wipe. I have tried reinstalling 3 times doing FULL wipes every time, still get the same. When I boot into recovery and try to wipe SDcard, I get an error saying

can't mount /dev/block/mmcb1k0p36 (Invalid argument)
Error mounting /internal_sdcard/!
Skipping format

I have also just tried the new 1-15-14 build and get the same results. I have fastbooted the boot.img each time. Please help. I have installed many ROMs on this device before w/o ever an issue. What did I do wrong and how do I fix it? TIA!
18th January 2014, 02:25 AM |#2  
rignfool's Avatar
Senior Member
Flag The Poconos
Thanks Meter: 2,364
Reboot recovery
Mount USB storage...
Plug phone into computer...
Let windows format corrupt partition...

Sent from my Vivid 4G using Tapatalk
19th March 2014, 08:57 PM |#3  
projectisaac's Avatar
Senior Member
Thanks Meter: 32
Just putting another method which worked for me (one time issue and fix, so it's a crap-shoot). I don't have the luxury of connecting to a computer via usb for anything except charging.

-properly flash a sufficiently different ROM (I had kitkat, so I flashed ICS)
-start ROM up, check if fixed (mine was not)
-mount the SD card in your recovery (mine is WCX recovery)
-reboot your phone into the ROM

This method worked for me. I saw in a different forum that when this happens it's usually because a file that describes the partitions gets corrupted and that because ICS and GB partition the SD cards and internal storage in a different way than Jellybean or Kitkat, that flashing a different ROM (if problem is on ICS/GB, then flash KK/JB, and vice versa) will force an overwrite of the file in question.

This is not as easy as rignfool's method, and once my charge port arrives in the post, I will abandon this method and use Windows to repair the partition like a sane person

Also, it seems like all my media on the internal storage has been wiped, but wutevr :/
20th March 2014, 06:46 PM |#4  
Thanks Meter: 3
Might want to try a newer build where that bug is fixed.
21st March 2014, 02:08 AM |#5  
projectisaac's Avatar
Senior Member
Thanks Meter: 32
Originally Posted by Yuskow

Might want to try a newer build where that bug is fixed.

If this is directed at me, this happened after I installed the March 17th or 18th nightly (put a new one on every once and a while). And to be completely fair, I had accidentally selected factory reset in hboot (thought it was highlighting recovery, boy was I pissed).

The problem (or so I've read) with installing another kitkat/jellybean ROM is that the SD card is mounted the same (/storage/sdcard0, and external SD is only /storage/sdcard1) as opposed to ICS/GB (I only remember that you access external SD through /sdcard/ext_sdcard or something to that extent). Only when the SD cards will be mounted at differing locations will the system re-write the files specifying mount points.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes