Remove All Ads from XDA
Thread Deleted Email Thread
Prev Previous Post   Next Post Next
I have Jiayu G3S MT6589 and phone was working perfect, I was keeping it in my pocket and yesterday i took the phone off the pocket and i couldn't boot it. I can't charge it either. I tried to put other battery in my phone and it still didn't boot up. But when i connect it by USB i can see that its MTK USB Port, or MTK DA port or something like this (that's after installing drivers, before I installed it i was getting Unknown Device on the list - it shold be MT65xx Preloader) So i tried to flash a stock rom (SP flash tool), but i can't do it too - I'm getting error connected with DRAM, or the red bar is loading like 100% and then nothing..I can wait and wait and nothing more...
I didn't broke my phone like it was never on the floor or something like that and I didn't change Preloader by SP Flash Tools
It's very important to me to fix it fast because I'm working on dual sim and I need smartphone... I don't want to send it back to China - it would take at least 2 months to complete repair, so I'm determinated to do it on my own, but I need your help...
Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes