Remove All Ads from XDA
Honor 9 Lite
Thread Deleted Email Thread
Prev Previous Post   Next Post Next
Resolved! See edit 2.

Today, I was trying to fix the 1SMS bug, as I've been unfortunate enough to come down with it a few weeks ago. One method suggested by several users was to run a `reboot nvrestore` in Terminal Emulator as superuser, with the admonishment being that this required a known working nvbackup.

Around the time of the CM 10.2.0 release, I had performed this backup following these instructions so I figured I was ok to proceed with a restore. Around this time, I had also upgraded my modem and firmware to ML1 and MF1 respectively, following these instructions, although I do not recall the order in which I backed up and installed the modem.

I ran `reboot nvrestore`, my phone rebooted as expected, and as reported in the 1SMS thread I entered into a softlock boot loop. Figured I would just re-flash CM 10.2.1 (I had upgraded when this version was released), so I tried to reboot into recovery. Unfortunately, I found that my recovery would not load. Uh oh.

My first thought was to get a recovery reinstalled, so I installed Heimdall (OSX is my primary OS), booted the phone into download mode, and went to upload the latest CWM recovery.img for my device. Heimdall reported a successful upload, but no blue process bar ever appeared on the phone. Uh oh.

I tried again with the latest TWRP for my device, but had similar (non-)results.

The phone is charging now, as I'm paranoid about running out of battery during one of these attempts. My next step is to try flashing a recovery from within ODIN itself (I have a Windows machine as well), but I wanted to see what the community thought of all of this. Anyone had a similar experience? How did you get back to a working recovery?

tl;dr `nvrestore` broke my rom and recovery, thoughts?

Edit 1: Probably worth also reporting the message lines on the ODIN download screen on the phone:

Product Name: SCH-I535
Custom Binary Download: Yes (4 counts) // from the failed recovery load attempts
Current Binary: Custom
System Status: Custom
Qualcomm Secureboot: Enable // this line worries me, although I don't know if it is a change from before the `nvrestore`

Edit 2: Uploading TWRP through ODIN 3.09 on Windows resolved the problem. Guess Heimdall still has some kinks to sort out. Was able to perform a factory reset, flash CM 10.2.1 and GApps, and the CM first-run wizard just launched. My only remaining wonder is whether this resolved the 1SMS problem in the first place, or if I just lost an afternoon sorting this out. At any rate, thanks for reading, and hopefully this can be useful to someone else in the future.
Subscribe to Thread

bootloop, softlock

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes