Remove All Ads from XDA

Need to flash Ativ S missing drivers?

741 posts
Thanks Meter: 68
By Loco5150, Senior Member on 24th March 2014, 06:05 PM
Post Reply Email Thread
Hi all.

I started experiencing weird problems with my Ativ S, so I thought I do a hard reset and start clean. I got stuck to a known issue with the Ativ and GDR3, where after hard reset the apps wont instal from the store. The only solution I saw was to flash the device. I have the GDR2 rom so I thought no problem, however I cant get the drivers to instal on the download mode so I could start the flash process.

I have tried to instal 2 different drivers: SamsungUSBDriver.msi and Neither of these (that I found, if they are the correct packages) have worked so that the Ativ is recognized correctly in the download mode and I could start flash. When Ativ is connected in the download mode, its only seen as USB DOWNLOADER with exclamation point at device manager.

Im running 64bit Windows 8.1 Pro system.

Any suggestions are welcomed! Thanks!
24th March 2014, 06:17 PM |#2  
Loco5150's Avatar
OP Senior Member
Thanks Meter: 68
And installing SamsungUSBDriver.msi results in an error pictured here. Although next time trying to instal the driver is present as it gives an repair option.
Attached Thumbnails
Click image for larger version

Name:	Untitled.png
Views:	135
Size:	21.5 KB
ID:	2647912  
24th March 2014, 06:47 PM |#3  
Loco5150's Avatar
OP Senior Member
Thanks Meter: 68
Ok so I found this, probably somthing that could be expected: 2. Install Driver on your PC (i had problems with win 8.1 X64, win7 X64 installation fine)

So I would need a Win7 system, no idea where I would have one... Other suggestions for this?
24th March 2014, 08:14 PM |#4  
Loco5150's Avatar
OP Senior Member
Thanks Meter: 68
Ok problem solved by installing Windows 7 to a empty drive just for this flashing. Luckily I didnt have to instal any updates, just the os and the usb driver.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes