Remove All Ads from XDA
Honor 9 Lite

[Solved] Can't click (install) on APK, then found the reason

431 posts
Thanks Meter: 71
By kschang, Senior Member on 26th March 2014, 09:43 AM
Post Reply Email Thread
This is an old problem, but the causes are so plenty it's a doozy. So here's yet ANOTHER cause of "can't click (Install)" button and its solution.

Any way, just updated to SlimKat. And no, I did NOT have official JB installed before, just official ICS, Safestrap, and had been running on CM10 ever since. But that's not the important issue.

Tried to reinstall some APKs, like Amazon store, some Xposed modules... Except none of them will let me click the INSTALL. And yes, 3rd party apps install is active, and I even turned off verify apps.

All of the previous advice I can find says look for screen filter or brightness apps or overlay buttons. I checked. Ain't got any that's active.

I was using PermissionDog to check anything that uses an overlay and uninstall them one by one, when something hit me (not literally). All of these are overlays of some sort. What overlay did I add recently? Then I looked at my screen, then slapped my forehead... hard.

I had enabled "battery bar" that comes with BatteryMix. This optional bar shows you a horizontal 2 px high bar on the very top that shows you your battery level. That is an overlay!

I turned that off, and voila, I can install APKs again. So let that be a lesson to you.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes