Remove All Ads from XDA

screen all of a sudden wont go on just flashes

633 posts
Thanks Meter: 60
By dragonfly1113, Senior Member on 2nd April 2014, 03:28 PM
Post Reply Email Thread
Battery was low this morning so plugged it in a few hours ago left it plugged in for a while didnt look at it once took it off charger went to power it on and the screen just flashes nothing is on it just flashes as if its going on but it doesnt, tried holding the power and home button and it says to press power for recovery or home for factory mode, tried both and nothing happends. Tried holding down the power button for over a minute and screen just kept flashing on and off every 2 seconds. Don't have my lil screw driver with me again i should just keep it in my pocket for battery pulls with the issues ive had lately.
Running a Callisto 100 with loki's most recent firmware release. any thoughts? other than battery pull when i get home?

edit: got home did battery pull tried again still didnt work noticed charger at work wasnt charging the watch when i had plugged it in i guess it was unplugged from under my desk. tried charging at home now alls good again
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes