Remove All Ads from XDA

Strange Root behavior - New apps can't get root

22 posts
Thanks Meter: 5
By akameswaran, Junior Member on 2nd April 2014, 09:06 PM
Post Reply Email Thread
I have had my tablet rooted since I got it pre-4.2.1. I was trying to setup TWRP as I finally decided to ROM my device and ran the unlock tool.

However, once I got past that and tried to use goomanager and TWRP manager, I realized apps were not being provided root any longer. However, the old apps that were approved in Superuser continue to get root and think that they have root, such as Titanium Backup, SManager, ES Explorer, etc. They continue to function as expected. However in SuperUser the logs have not updated in quite a while.

I've done several steps and reviewed a few related threads. Changing the prompt settings have not done anything, and I've tried several combinations of setting it to allow, setting it to prompt, rebooting etc. To confirm root is actually working I ran SManager and ran /system/bin/su which does work, and causes SuperUser to show new root access. Along the lines, I've nuked my dalvik cache using SManager and rebooted.

However, nothing else updates the logs, and new apps do not get root. Based on some other thread, I used voodoo OTA rootkeeper to remove root and then ran motochopper. Root came back, but continues to have the same behavior. SuperUser is unable to update itself, although it does show the binary as up to date. When I try to run an update anyway, it fails at the getting root step. SuperSU, rootchecker, android root toolkit all fail.

I am hoping I can figure out how to fix this, even though I unlocked the tablet, I'm traveling and not in a position to flash in TWRP. Since running SU works and previously approved apps also work - I think there is someway to restore full root capabilities. Any suggestions are appreciated.

ASUS Transformer Infinity TF700 - rooted/stock
Motorola ATRIX 4G - Rooted/Currently Stock/No longer in use - anyone need a guinea pig?
Motorola ATRIX2 - vanilla
ASUS Transformer TF101 - now vanilla and given to the wife
Really I swear I've had lots of roms on these devices at other times.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes