Remove All Ads from XDA

[Q] Z1 Compact Chinese version M51w - google services not available but needed

2 posts
Thanks Meter: 0
By mic001, Junior Member on 20th March 2014, 06:36 PM
Post Reply Email Thread
Dear all,

desperately I am looking for a solution for a kind of very stupid and annoying problem:

I bought my Sony z1 compact in China. Model version: M51, Also called "colorful" in China
This Phone has a for China modified Android version installed. Nothing related to google works.
Well, sure the search engine in the browser. But I need the calendar, play store, etc.

Now I am thinking, has anybody experience with this device? ( only find posts to D5503)
Would it be possible to just update it with an international version? (Android 4.4 firmware 14.3.A.0.681)

Do i need to root, unlock Bootloader, or should a "normal update" work was well?
Or any other suggestions how to proceed?

I come the Apple world, where a jailbreak is one download and one click, I rooted a Xiaomi 2s with some small difficulties, but this looks way more complicated with this phone.... So any help would be appreciated..

23rd March 2014, 08:57 AM |#2  
OP Junior Member
Thanks Meter: 0
Arrow solved!
Well, developers,

forums are something strange. I really thought that anybody had a suggestion, a thought, an idea or whatever... 70 views and not a single answer.
Sure i could figure out that a root would help of course, but for a newbie like me, all of the descriptions have gaps and require much more knowledge about it, so that there is still a huge risk to screw it up and to maybe not destroy the phone, but to make it not usable until another solution is found.

Since I needed the phone, for receiving calls and SMS, i needed to go the less risky way and in the end - risk was still there ( is the M51w restricted to china and will not handle the firmware of the D5503) I followed the guide on the

"xperiafirmware" page called "Sony XPERIA Z1 Compact D5503 - Android 4.4 - firmware 14.3.A.0.681" ( sorry, cannot post links yet)

I just flashed the Android 4.4 - firmware 14.3.A.0.68 made for the d5503 (according to the guide "1. how to install the newest Android 4.4 for Sony XPERIA Z1 Compact D5503") it worked with out any problems.

One thing that might be misunderstanding is the Flashtool.
After downloading the flash tool its not called "Xperia flash tool", it looks the same as the "androxyde flash tool", and there is a second one which is the " Sony flash tool that is called "Emma" but the flash tool.
So,... just use the one this author linked in his guide, and don't get confused by the names..

Now I have my problems firstly solved. But have to say that, with that some others come...
- Google account sync seems to be not really under my control
- two google accounts even more hard to handle
- and further settings very limited, so that I sometimes even have the feeling i was free with iOS. And the Xiaomi of course let me taste the complete taste of freedom.
- SD card management
- Walkman
- album folders

Well , I will figure that out as well.
Hope this post will help somebody!
23rd March 2014, 09:14 AM |#3  
Senior Member
Flag Iloilo City
Thanks Meter: 1,770
Donate to Me
Just my 2 cents... Downgrade back to android 4.3 I'm pretty sure some of those problems will be solved. And another is Chinese version of Z1C doesn't have LTE support and since you flashed an international version of the ROM LTE might show up in the settings but there's a huge chance it will not work or possibly cause errors. Phones made for chinese market doesn't have google installed because google is blocked in their country. Just a FYI Never noticed your post so I didn't get to assist you before this but seems like you made the correct choice on solving your problem.
23rd March 2014, 03:33 PM |#4  
Originally Posted by mic001

so that I sometimes even have the feeling i was free with iOS.

Once you get fully up and running, you'll LOL like the rest of us reading that. In this kind of situation you are kind of on your own because until you've tried you'll never know and most of the People reading wont advise you to do something that could potentially hard brick your Phone. You've done what I would have done which is grab an ftf and tried it, not much more you can do.
5th April 2014, 05:02 AM |#5  
Junior Member
Thanks Meter: 0
Same problem
Hi Mic,

I want to follow your example with my Chinese Z1 Compact. Are you still around, in case I have some questions? Have you tried to fix the other problems you mentioned? Any new comments? I am going to try to understand the procedure but I would feel better if I could pick your brain in case I get stuck.


Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes