Remove All Ads from XDA

[Q] Stuck! Phone does't turn on and does not charge

1 posts
Thanks Meter: 0
Post Reply Email Thread
Hello guys I have been struggling for the past week, my LG G2 phone has been rooted, I flash a custom recovery TWRP then I lunched to my stock rom I then tried to update my firmware to 4.4.2 kitkat the update was downloaded successfully, then it told me to reboot, so I did phone switched off then I was stuck on a boot loop but this time it was a boot loop with a error message on the left top corner. and then it would take be to a dim back screen. I searched the entire week to find a method to get me through the start screen and I found this -> NO Recovery mode, No download mode, after OTA on rooted LG G2 I done exactly what it was showing, then my phone switched off and now it won't power up. Then I tried turning it on NOTHING phone does't show the LED charging lights, does't respond to the usb being plugged in can't do ANYTHING I am guessing the battery has died so now I don't know what to do, either contact LG or should I try getting a battery that is fully charged or even use a factory cable any ideas guys ?
7th April 2014, 12:25 PM |#2  
NEO2598's Avatar
Senior Member
Thanks Meter: 220
Call LG support.

Sent from my g2 using Tapatalk
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes