Remove All Ads from XDA
Honor 9 Lite

8" - Compass and Tilt misconfigured

25 posts
Thanks Meter: 12
By bsquare, Junior Member on 9th April 2014, 02:18 PM
Post Reply Email Thread
I've searched around and so far I haven't found anyone else who has this issue, so I thought I'd throw it out here:

I noticed that the compass was never working, in google maps, gps tools, or Ingress, so I downloaded "Phone Tester", and it shows the compass as almost completely static when I rotate the tablet on a flat surface. The pitch and roll change just fine. The other odd thing is that when I tilt my device up or down, which should only change the pitch, the compass shows different angles, as if the reading for the compass was coming from the pitch instead of the magnetic pull.... odd.

Here are some things I've tried:
1. Complete wipe of rom, system, data, etc.
2. Stock roms and CM11
3. The built in kernels for the stock rom and CM11, as well as blackhawk's kernel (v1 & v1.3)
4. Calibrating the compass via "GPS Status" app (multiple times)
5. In an act of semi-desperation I tried a suggestion to take a weak magnet and run it around the top corners of the tablet to "unstick" the magnetic sensor. Interestingly enough, that changed the sensor reading, which confused things even more for why it would be connected with the pitch instead of magnet compass pull.
6. Removing it from it's case. Using a different case. Tapping it gently, again to "unstick" the sensor?

I would be grateful for any ideas and/or collaboration if anyone has had the same issue.

EDIT: It seems that the sensor was simply stuck. I took it out of the case again and ran a kitchen magnet along the edge. This time it released it to work properly, though the magnets in both of my tablet cases seem to be pulling it in wrong directions.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes