Remove All Ads from XDA

[Q] [HELP]Microphone and speakers stop working

79 posts
Thanks Meter: 12
By Jumnhy, Member on 8th April 2014, 05:31 PM
Post Reply Email Thread
I had been doing a great deal of tinkering trying to get my phone's battery life back in the last few days, and I made good progress, but I severely jacked up something related to the microphone/speaker/video recording.


The problem, as far as I can tell, is that every app that tries to access the microphone can't do it--this shows up when I try to use Google voice input in various text fields with a little "Can't reach Google at the moment." Same with trying to do a search by voice in Google Now--brief brief flash of the microphone red, then back to gray, with "Can't reach Google at the moment". Additionally, my Touchless Input cannot be enabled--the box has automatically unchecked itself, and pressing it makes the button get a little gray, registering the action, but no checkmark will appear.

Additionally, other apps which would use the mic don't seem to have that functionality--Evernote, for example, would crash if I attempted to record an audio clip. This was before I performed a factory data reset last night--and the problem has persisted regardless.

There are two other, seemingly related, issues. First is the inability of the phone to capture videos. The camera opens fine, and I can take fine stills with it, but pushing the video recording button makes the red "record" flash for a moment before a "Not able to record media" message pops up, and the camera returns to the still photo mode.

Second is the inability to play videos. I have tried playing videos in as many formats as I could try, from within several players, including the stock "Photos", "Gallery", and "YouTube" apps. "Sorry, cannot play video" pops up, or the app simply crashes. Similar story for attempting to play music through the stock "Google Play Music" app. And it gets worse. I can't make or receive calls. Actually, let me revise that. I can't hear anything being said on the calls, over the speaker, or through headphones (though I've yet to try BlueTooth). The call appears to connect, but I can't hear anything from them, and they can't hear anything from me.

So--that's the basic summary of the problem--threefold.
1. No audio input through mic
2. No audio output through speakers--my phone doesn't ring when I get a call, although it will vibrate and the options to take the call appear as they normally would.
3. No audio/video playback whatsoever for other media.

I'm running Android 4.4 on a Droid Mini, unrooted, and I just completed a factory reset last night.


Here's the wrinkle. I know this isn't a hardware problem, because I have found a surefire fix that makes all of this work properly if I absolutely need it, it just sucks. Rebooting into safe mode is what does it. Playback resumes as it did before I had the problem. I can play videos, pump music, and Touchless Input works flawlessly--although interestingly, it has me re-enter the catchphrase three times every time I get into safemode, like setting up from scratch.

My consternation comes from the fact that, to my very limited knowledge, all that safe mode is doing keeping any user-added apps from running. Which is all well and good, but I just did a factory reset. Literally when I boot the phone no user installed apps are running, and yet there's a definite difference when I boot into safe mode, cuz everything works there.

So, safe mode must do something more than just disable user-installed apps--and I need to know what that is if I'm going to fix this thing. I have added 4 apps since then-- App Ops, GSAM Battery Monitor, BetterBatteryStats, and Button Savior (Non-root), all of which I know from experience to be very "well-behaved" apps.

Anyone know what safe mode is doing besides disabling user apps? Along those lines, does it revert updated stock apps to their factory state? I ask because very, very briefly, while my phone was slowly trying to upgrade the 40-odd pieces of Bloatware from the Play Store, the microphone was working. Which makes me think that the culprit is one of the system apps in it's updated form. If safe mode runs these apps as they originally appeared on the phone, that might explain it. It would also hopefully let me painstakingly disable these apps, one by one, to find the culprit and disable it.

I say culprit because of something I stumbled across trying to research this--weirdly enough, in a message from the devs of Shazam. devs of Shazam They say that the issue has shown up on 4.4 and the cause appears to be one app somehow monopolizing access to the microphone. I could see this breaking the video as well, and potentially the audio playback if, as I assume, Google uses the mic to help tweak the sound of the speakers.

Anyone know any more about any of the aspects of this? I will be posting back myself as I learn more.
8th April 2014, 11:15 PM |#2  
Senior Member
Thanks Meter: 337
What happens if you factory reset without restoring any apps? In other words, factory reset, choose not to restore your apps (or don't attach to a Google account on initial setup, and do it post-setup). In other words, do you have an app that is blocking this access?
The Following User Says Thank You to doogald For This Useful Post: [ View ] Gift doogald Ad-Free
10th April 2014, 05:48 AM |#3  
OP Member
Flag Saint Paul, MN
Thanks Meter: 12
Originally Posted by doogald

What happens if you factory reset without restoring any apps? In other words, factory reset, choose not to restore your apps (or don't attach to a Google account on initial setup, and do it post-setup). In other words, do you have an app that is blocking this access?

Trying this now. Thanks for the suggestion!

Update: Tried this. Did another FDR, signed in to one of my Google accounts afterwards, but haven't updated a thing. The audio/voice/video/bugs seem gone; however, the ****ty battery drain I had before is back. I'm playing around with some settings to find out what can be done. I'm also going down the list and updating the system apps one by one.

Does anyone know a good testing process (ie, should I run the app? do I need to restart after install? run the app and close? etc) that will keep me from getting false negatives (ie thinking an app isn't causing the problem when it is)?

Update again: I'm working down in alphabetical order through the factory apps. However, after the most recent factory reset, it appears that my battery drain is back, and as long as the battery drain is there, the phone works normally. So, not looking good in terms of battery+functionality for me. Went through the 40ish apps that were on the phone stock--after the fresh reset, the phone is working, but the battery life is shot to **** all over again. Not sure what to make of all this, and now back to being frustrated with a 4 hour battery life from the phone that never sleeps. UGH

Update yet once more:
For kicks and giggles, tried unchecking the "Touchless Control" in settings, to see what effect that would have on my battery. But, reasoning that whatever wakelock was keeping my phone up all the time had to be persisting after it was needed, I guessed I needed to reboot to get rid of them. Booting up again, I'm back to battery life without audio/video/etc. Very confused here. Apparently it has nothing to do with the apps installed, period.
21st February 2017, 04:06 PM |#4  
Junior Member
Thanks Meter: 0
Facing the Same problem please someone tell me What should i do
30th March 2017, 01:12 AM |#5  
Thanks Meter: 2
Same problem! No audio call

Inviato dal mio Redmi Note 3 utilizzando Tapatalk
25th April 2017, 03:57 PM |#6  
Junior Member
Thanks Meter: 0
Please help me I have this same problem. No audio, cant play video, nd mic isn't working.
Post Reply Subscribe to Thread

microphone, not hardware, speaker, video

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes