Remove All Ads from XDA
Honor View 10

[SOLVED] (I think) Problem with Google services

14 posts
Thanks Meter: 0
By jbyersak1015, Junior Member on 10th April 2014, 09:32 PM
Post Reply Email Thread
So i had posted before that I was having issues with my Google services. I was unable to get into Play Store, Gmail, Hangouts, anything that goes through a Google server. I tried wiping everything, force stopping, clearing cache, all the basic fixes. It worked again after I would flash a new ROM for a while. Nobody could figure it out. Samsung was stumped, AT&T was stumped, and a few guys on here were stumped. AT&T sent me a new phone and things were working great. Rooted, ROMd, everything. Went about using my phone as normal. Then, a couple days ago, the same thing started to happen.

A thought popped into my head today. On all ROMs I tried to use I always installed Freedom for free in-app purchases. I also installed it on this phone, but only on the custom ROM. I have been using the stock ROM perfectly. I went into Freedom and stopped it properly by pulling up the settings menu and hitting Stop. Then I uninstalled it. Straight away I went to Play Store and I had access again. Same for Gmail.

So my assumption is that Freedom caused the issue. It took a while because I havn't used Freedom in a month or so and the issue just started happening. However, once I removed it properly everything worked fine. When I wiped my old phone I never removed Freedom so i'm not sure if that messed something up that a basic factory reset couldn't fix. The other reason this is an assumption is because I was not able to test this on my old phone. But I figured I would let you guys know. If you have issues with Google services and have Freedom installed, try uninstalling it. But first, MAKE SURE YOU STOP IT FROM THE IN APP SETTINGS!
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes