Remove All Ads from XDA
Honor View 10

One workaround for 'assert failed' during CM install

418 posts
Thanks Meter: 52
By PMikeP, Senior Member on 11th April 2014, 01:46 AM
Post Reply Email Thread
Error message during failed install of CM zip: assert failed: get prop ("ro.product.device") == "ovation" || get prop ("") = ="ovation"

Solved: See below.

When I first got my HD+, I did an SD "install" of CM 11. Then I installed CM 11 to the emmc, via CWM, per all the instructions on the xda website.

Once CM 11 was installed, I changed to TWRP (I like being able to name the backups.)

Then I did a wipe and dropped down to CM 10.2.1. (More stable.) I did the install from TWRP.

Then I installed the fuzz kernel from TWRP.

Last, I updated to TWRP when I couldn't get Succulent's CM 11 to install.

Okay, so tonight I wanted to do a clean install of CM 10.2.1, without gapps this time.

So I booted to recovery, did a wipe, and tried installing CM 10.2.1.(The build came direct from Cyanogen mod's website for the Ovation.)

I get an error similar to what I got when I tried to install Succulent's CM 11. Here's the error message:

assert failed: get prop ("ro.product.device") == "ovation" || get prop ("") = ="ovation"

I dropped back to CWM and tried installing the ROM from three different versions: CWM,, and CWM

I tried installing CM 10.2.1 from the internal and the external SD card.

No joy. Fortunately, a Nandroid backup beforehand and I've restored to where I was.

Any ideas what's wrong? It shouldn't be this hard. It doesn't seem that a ROM install should be Recovery Dependent . But maybe it is?


Solved. leapinlar, in the thread where I originally posted this question, said to use an older version of CWM to install. Apparently some incompatibility between versions of CWM (and TWRP) and the ROM zip.

Another solution was alluded to by King200 in another forum, but it sounded arcane and hard to do. It wasn't.

Here are Windows instructions:
Note: This method removes the "sanity check" built into the recovery image which checks to make sure the ROM you're installing is compatible with your tablet. Obviously, flashing the wrong ROM can/will brick your tablet.

So be warned.

Since I only have one tablet that I flash CM 10.2.1 on, no problem for me. If you have more than one tablet, perhaps you should delete your hacked zip after you install, to be safe.


But for educational purposes, here's what I did to work around the problem.
You do this with 7-Zip. (So install 7-Zip if you don't have it already.)

Right click on the ROM that you're trying to install.

A 7-Zip context menu opens.

Select "Open Archive."

Drill your way down to


Right click on the updater-script and select "Edit."

Open updater-script with Notepad.

Delete the first line of code, all the way up to the first semicolon. And delete the first semi-colon as well.

Save the edited file in Notepad. You'll get a 7-zip message asking if you want to incorporate your changes back into the archive. "Yes."

Now the ROM will install with later versions of CWM or TWRP.

Note: I had to do with this with the "fuzz" kernel too.

P.S. I don't know how to read code, so I don't understand exactly what the problem here is. I peeked at the scripts. I have an "ovation" tablet. Both the ROM and the Recovery image mention "ovation" in their updater scripts. Seems like they ought to talk to each other.
11th April 2014, 02:39 AM |#2  
leapinlar's Avatar
Recognized Contributor
Thanks Meter: 3,870
Donate to Me
Please don't do this procedure. It is dangerous. It could brick your device. And the issue is not whether you have more than one tablet, it is if you accidentally download a hummingbird (HD) zip when you have an ovation (HD+) and try to flash it to an HD+. If you remove that assert statement the HD zip will merrily install to an HD+. And you will have a real mess.

A real case happened where a Nook Color user tried to flash a Nook Tablet ROM to his Color. The assert statement which was designed to prevent that did its job and prevented it. However, another user recommended he remove the assert statement, which he did, and thus flashed the Tablet ROM to his Color. His Color ended up bricked.


There are two more safe procedures.

One, use an older version of CWM to flash the older zips.

Two, do as the procedure says by opening the archive, but don't edit the updater-script file to remove the assert line. Look in a newer zip like CM11 and extract the file 'update-binary' and copy it to the old zip replacing the old update-binary file there. Then the old zip is flashable with the newer CWM/TWRP recoveries.

Sent from my BN NookHD+ using XDA Premium HD app
Post Reply Subscribe to Thread

assert failed

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes