Remove All Ads from XDA

My experience with KFU. Tips and tricks.

1 posts
Thanks Meter: 0
By jasassin, Junior Member on 11th April 2014, 04:10 AM
Post Reply Email Thread
I got the Kindle Fire Ftility 0.9.9 and ran the install_drivers.bat and then plugged in my kindle fire. This is where I encountered my first problem. I had already rooted and installed cyanogenmod 10, so Windows was seeing the Kindle in device manager as a portable device. Go into your kindle go to settings > about tablet > and click on build number until it unlocks developer mode. Then under settings go into developer settings and enable usb debugging mode. Next, click on settings > storage > and the settings box in the upper right hand corner and click usb settings. Uncheck the Media Device MTP. Now when you connect the kindle it will show up as an ADB composite device and will not be listed under portable devices. Now when you run run.bat it should say adb online, you might see boot status unkown. If you see boot status unknown power on your kindle slide the thing and it should be asking you to verify an rsa key. Click ok on your kindle. Now when you press the number for refresh status in Kindle Fire Utility you will see it online, and the bootmode should say 4000.

Now to the second problem. I've got the kindle fire utility running adb is running boot mode 4000 everything looks good. I press 2 in Kindle Fire Utility to do all of its magic it reboots in fast mode and then it locks up. No matter what I did I could not get it to work. After booting in fast mode it sees the kindle fire as an unknown usb device and updating the driver and leading it to the .inf file included with the kindle fire utility would not work, giving me the error message that it is an incompatible driver. I was reading about not trying this with USB 3.0 ports and sure enough this stuck on fastboot mode did not happen when I brought my kindle into my bedroom computer with USB 2.0 ports and ran the same kindle fire utility 0.9.9 and pressed 2 to let it do all its magic and it rebooted the kindle into fastboot and then windows detected it and it all worked perfectly. I've got the new twrp and kitkat cyanogenmod 11 running fine.

Debug mode, and USB 2.0 ports. (Windows not detecting the kindle after going into fastboot mode was particularly frustrating. On the USB 2.0 computer it just worked as easily as I think it should have in the first place.)

When you've got KFU running and you press 2 in its options and get your kindle totally rooted, don't forget to go back into your kindle settings > storage > and click on that box in the upper right hand corner and usb settings, and turn back on your MTP... so windows will see your kindle next time you wanna copy something to it. :P
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes