Remove All Ads from XDA
Honor View 10

[Q] HELP!! My GS3 doesn't connect to my PC and is stuck in the recovery download mode

3 posts
Thanks Meter: 0
By TheNative, Junior Member on 14th April 2014, 12:08 AM
Post Reply Email Thread
So my GS3 is about a year old and the charging port gave out while trying to return to a stock touchwiz rom (4.3 to be exact). So i got worried and went to a local phone shop where they fix phones and told them to replace my charging port. As asked they did replace the port with a new one and it works for charging, but it doesn't fully connect to my laptop. I've tried replacing the drivers at least 10 times, I tried going into download mode to see if odin would detect it and as thought it did not appear in the dialog box, and I've tried over 5 different data cables including the original one that came with it, and I tried restoring to stock with Samsung kies both versions and the phone never came up either. Anyway my question was is it something they did or is my phone not going to work anymore. I'll provide some pictures with the things I've tried. Please reply quick this is starting to worry me a lot (I wasn't this worried when i fell off my atv). i forgot to add that when i connect it the phone turns on but doesn't connect to the laptop is it something i did or was it the repair
Attached Thumbnails
Click image for larger version

Name:	000_0001.jpg
Views:	1172
Size:	264.2 KB
ID:	2684579   Click image for larger version

Name:	000_0002.jpg
Views:	999
Size:	271.1 KB
ID:	2684580   Click image for larger version

Name:	20140413_164905.jpg
Views:	1016
Size:	196.0 KB
ID:	2684581   Click image for larger version

Name:	20140413_164936.jpg
Views:	723
Size:	172.8 KB
ID:	2684582   Click image for larger version

Name:	20140413_164959.jpg
Views:	741
Size:	240.1 KB
ID:	2684583  
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes