Remove All Ads from XDA
Honor View 10

Android phone auto-brick itself overnight

1 posts
Thanks Meter: 0
By gaellafond, Junior Member on 12th April 2014, 03:56 AM
Post Reply Email Thread
When I woke-up this morning, my android phone (Galaxy SII Plus - Default kernel android 4.1.2 - not rooted) was off. I turned it on and it did some "Application optimisation". It automatically rebooted a few times, than I tried to used it. It was very unresponsive. Android keep popping up messages saying that apps like Skype, Google Plus, Google Play Store, etc. crashed. I was really pissed, I never asked for that "update" (or whatever that was) in the first place (I set it to NOT do any update automatically)...

It was completely unusable. It was constantly automatically rebooting. Eventually it popped up the "Application optimisation" message again, the screen turn black and never came back. I waited for about 30 minutes thinking it might be doing something hardcore... but nothing happen.

- Buttons -
I tried to remove the battery, press any combination of "Home" + "Volume up / down" + "Power" buttons but nothing works. The screen stays black, no sound, no vibration, nothing. I can't even go into "Download mode".

What was that update??? How come an automatic Android core update brick my phone??? Did someone manage to steal Android private keys using the OpenSSL Heartbleed bug and impersonalised Android to push malicious updates? I bought my phone in an other country, so I can't go back to the shop. What can I do?

BTW I'm on Ubuntu. I have been using almost exclusively Linux for the last 20 years so feel free to give hardcore suggestions / command lines. I'm also willing to put the screwdriver in the phone if that can help...



------ EDIT ------

- Heimdall / OneClick.jar -
I just tried the OneClick.jar method. It didn't work. I think I have to go into Download mode which is currently impossible.

------ EDIT ------

- Odin / Kies -
I installed the USB Drivers, Odin and Kies Files on a VM. When I put the battery in the phone, I can see the USB device in the VM (at lease I know that the VM can see the phone) but it's identified as "Unknown device 0A5C:E720 [0202]". The device vanish after about 2 minutes. I assume that the phone run something very low level, like a BIOS, than shutdown the whole thing for some reason. Neither Odin nor Kies can see the phone during that 2 minutes.

But the good news is, something actually happen when I put the battery in. There is no sign of life on the device itself but I can see something from the computer... There is life inside, so there is still hope. If I could put it in Download mode, that would give me more options.

How likely is a USB JIG device to work on such phone state? It's sending something through the USB port, so maybe it would listen to the JIG and go into Download mode...

------ EDIT ------

I made a USB JIG from a 270k ohm resistor, some hair thin copped cable and piece of cardboard. It's not pretty, and I don't think I will be able to use it more than once, but it worth a try...

The micro USB female connector is tiny. I'm pretty sure the 2 cables were on the right spot, and I tested the JIG to be sure the 2 copper cables do not short cut themselves before putting the battery in. The reading from my electric tester was 270k exactly, so the bundle is safe. I put the battery back in, waited a few seconds, but nothing happen...

I'm not 100% sure that my JIG works (maybe the copped cable were not pressing down hard enough). But I don't think any JIG can save my phone at this point.

- JTAG ? -
I had a look at some JTAG. That looks over complicated, but that's probably the only way I can reset the boot loader. Those things are very expensive. I will think about it. I'm not even sure the boot loader has been modified. My phone is not rooted, as long as I know, that partition is RO so even a virus could not mess with it...

Would I see the Samsung Galaxy logo if I boot the phone and the boot loader were ok? Or is that logo part of the OS?
14th April 2014, 03:23 PM |#2  
194989's Avatar
Junior Member
Thanks Meter: 0
Wow...hope everything works out well for you

Sent from my T-Mobile myTouch Q using xda app-developers app
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes