Remove All Ads from XDA

[Q] Encrypt phone feature bugged on Defy starting from 4.0

2 posts
Thanks Meter: 0
By Neokaos, Junior Member on 7th April 2014, 11:59 PM
Post Reply Email Thread
Hi Guys,
Has anyone tried the encryption feature found in Security settings? I'm using a recent nightly CM11 from Quarx/Blechd0se (Thanks, brilliant work!) quite stably for days now, but fail to make the encrypt phone function work...
When fully charged and USB powered, which are requirements, the successive encrypt phone buttons end up on a green android picture. This screen misses text and a progress bar which should normally appear on top of the screen, as seen on some screenshots. Even left for several hours, nothing progresses and a simple press on back button cancels action immediately which proves nothing has been encrypted in the meanwhile.

Took a Catlog and the only interesting message is the following:
01-02 01:34:23.732 E/Cryptfs ( 1197): Cannot get size of block device
In case it helps, find attached the output of mount command : mnt.txt

Could you have a look / help me out? (add to bug list if it applies)
In fact, for me, this function needs to be activated for connecting to my professional mails ...
Thanks in advance!
15th April 2014, 12:19 AM |#2  
Neokaos's Avatar
OP Junior Member
Thanks Meter: 0
Info 2 Further tested...
Hello all,

Just some more info... I flashed back to Quarx' CM9 and quickly tested once more the encryption and face the same problem but I didn't catlog, neither checked the mounts... Then I flashed Epsylon3's CM9 and quickly checked with the same result too...

But then I checked at catlog and now I get another type of error... Which is interesting and maybe promising as I already read some posts about this message...
04-14 21:11:13.101 E/Cryptfs ( 2219): Orig filesystem overlaps crypto footer region. Cannot encrypt in place.
Problem seems to be more general than only Quarx/Blechd0se's CM11 but a friend uses a CM9 flavor on a Samsung Galaxy S and has encrypted the phone successfully...
All in all it's linked with the filesystem (block device or not), how it is formated (yaffs/ext3/ext4) and mounted (mount/mount_all)...
Some interesting reading on (not linked, I don't have 10 posts yet)...

Hope to find, test and come back with some more info soon...
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes