Remove All Ads from XDA
Honor View 10

[Q] HELP! No Service - SOLVED!

640 posts
Thanks Meter: 151
Post Reply Email Thread
I hope someone can help me.

I stupidly flashed ViperOne on my HTC One with C Spire Wireless without reading the thread thoroughly. After I flashed the rom, I got several force close errors and the phone kept rebooing itself about every 2-3 minutes. I rebooted in recovery, wiped data/cache/dalvik cache ect and went back to Liquid 4.3. I have noticed now that I do not have any phone service nor do I have any data connection. I tried to flash CM10 to change my CDMA Subscription but the settings do not stick. The settings keep reverting back to NV instead of RUIM/SIM.

I also noticed on my bootloader, the radio version and basband are missing:

OpenDSP - v31.120.274.0617

It appears that I have no radio? I have the radio from C Spire Wireless in a .img format and a flashable zip. I have flashed the radio repeately and despite twrp saying the flash was successfull, I still have no phone service. I confirmed in my sim card app that the sim card is working fine. Does ViperRom contain its own radio? Do I have some firmware missing? Any help is appreciated. All i have is a fancy paperweight right now.

FYI: there is no RUU for my carrier


C:\mini-sdk>fastboot getvar all
(bootloader) version: 0.5
(bootloader) version-bootloader: 1.55.0000
(bootloader) version-baseband: N/A
(bootloader) version-cpld: None
(bootloader) version-microp: None
(bootloader) version-main:
(bootloader) version-misc: PVT SHIP S-ON
(bootloader) serialno: FA3A2S902212
(bootloader) imei: 990001462237926
(bootloader) meid: 99000146223792
(bootloader) product: m7_wls
(bootloader) platform: HBOOT-8064
(bootloader) modelid: PN0720000
(bootloader) cidnum: UTSI_005
(bootloader) battery-status: good
(bootloader) battery-voltage: 3868mV
(bootloader) partition-layout: Generic
(bootloader) security: on
(bootloader) build-mode: SHIP
(bootloader) boot-mode: FASTBOOT
(bootloader) commitno-bootloader: dirty-371c4f408e
(bootloader) hbootpreupdate: 11
(bootloader) gencheckpt: 0
all: Done!
finished. total time: 0.031s
18th April 2014, 09:12 AM |#2  
Sippi4x4man's Avatar
OP Senior Member
Flag Gulfport, MS
Thanks Meter: 151
For those who would like to know how I fixed this, SPECIFICALLY C SPIRE WIRELESS USERS,

I changed my CID to match Sprint - SPCS_001, instructions are here:

I then relocked my bootloader using the command: fastboot oem lock

Downloaded and ran the latest Sprint RUU from here: **if you do not change your cid, the RUU will not work**

Once the RUU was complete, I then unlocked the bootloader via HTC Dev:

I then flashed TWRP recovery via fastboot

Flashed Liquid 4.4.2 from here:

Once everything booted up, I was back on C Spire Network with working voice and data. I also changed my CID back to C Spire - UTSI_005.

If for some reason you don't have voice or data, you can flash a CM10 rom from Cyanogen's website, go into Settings-More-CDMA Subscription and change the setting from NV to RUIM/SIM.

If the above doesn't work, here is a flashable C Spire Radio :
The Following User Says Thank You to Sippi4x4man For This Useful Post: [ View ] Gift Sippi4x4man Ad-Free
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes