Remove All Ads from XDA

[Q] Stuck on T-Mobile 4G LTE screen after flashing via odin

101 posts
Thanks Meter: 4
By itzstevo, Senior Member on 21st April 2014, 10:10 PM
Post Reply Email Thread
I started off with a completely stock 4.1.2 Samsung Galaxy Note 2. Everything worked fine until I decided to rooted and flash a 4.4 rom. Everything seems to work except I couldn't any network signal. Wi-Fi worked. IMEI showed up.

Tried with a 4.3 roms, same results.

Read somewhere that I would need to flash the official 4.3 t-mobile samsung galaxy note 2 firmware and it would correct the problem so I downloaded the firmware from SamMobile flash it via odin. It rebooted, but I'm stuck on the T-Mobile 4G LTE screen. I am able to reboot in to recovery and download mode.

What should I do next or am I screwed? Should I download the latest 4.1.2 and flash it via odin? Can I downgrade firmware?

Left it on the T-mobile 4G LTE screen for about 10 minutes now.
22nd April 2014, 01:13 AM |#2  
Senior Member
Thanks Meter: 243
Try factory reset from recovery. If that does not work then try formatting /data before flashing stock rom via odin.

Sent from my SGH-T889 using xda app-developers app
22nd April 2014, 03:25 AM |#3  
Coug76's Avatar
Senior Member
Flag East of Seattle
Thanks Meter: 975
Since you flashed 4.3 via Odin you can't go back to 4.1.2 via Odin without issues. The 4.3 bootloader sticks like something that is really really stuck.

Do a wipe like advised above and reboot (as above). Since you have the bootloader you will good Wi-Fi. Make certain your modem is correct for your device model (MK7 is right for T889). Wipe cache and dalvik, then reboot and let sit untouched for 10 minutes, reboot. Check for signal.

BTW who is your carrier? You may need to check that your APNs are correct.

Hastily spouted for your befuddlement
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes