Remove All Ads from XDA
Honor View 10

[Q] Woes of the S4 mini SCH-I435 (several questions about it)

2 posts
Thanks Meter: 0
By NolanSyKinsley, Junior Member on 22nd April 2014, 05:34 AM
Post Reply Email Thread
I was recently given a new SCH-I435 from a family member. This is my first time having an android in a very long time(Switching from an iPhone 4s). I have a few questions about it. (this may be a lengthy post)

First I know that you cannot flash custom ROMs to it, as the bootloader is still locked. I have heard that there are some de-bloated stock ROMs out there, but have entirely failed to find any. I can probably get by without it, as I already have it rooted, but there are several things I am attempting to do, and every time I look up how to do it, step one is having a custom ROM.

If anyone can point me to a de-bloated stock ROM I would greatly appreciate it (or at least one that is compiled to not be a "production build" as I keep running into "adbd cannot run as root in production builds" and it is severely limiting what I am trying to do, and what I am going to want to do in the future)

What I am trying to accomplish next is taking over the "connected as installer" feature that Verizon has on it when you plug it into USB (I am using linux exclusively so have absolutely no use for their software). I figured I may as well put this feature to good use. I am attempting to swap the ISO file in /system/etc for a CrunchBang LiveCD.

This has only been a partial success, apparently /system is it's own partition, and there is not enough room to fit the whole ISO (It is 739mb and it stops at 423mb) Even though it does not get the whole ISO copied, if I reboot my computer the ISO does indeed boot into the options, but fails to load the live session (no brainer there) so I know I am on the right track. I don't want to use DriveDroid for this, as it is very very finicky, and only seems to work 1 out of 6 times (and that is a kind guesstimate) My guess it that the "connected as an installer" is messing with it, so I would hope to turn the problem into the solution.

So I either need to find a de-bloated ROM that can free up ~ 400mb on /system, find a way to link the ISO from elsewhere on the device (I tried a soft symlink from my SD card and that did not work, it opens the ISO as an archive and not a file system), find a way myself to free up ~400mb on /system, or find a way to re partition /system to be larger (I have the 16gb S4, so I have plenty of room to spare).

I would prefer the debloated ROM(I don't know if that will free enough room), but finding a way to re-partition would be a close second (Every guide I have found for re-partitioning starts of with "First you need cyanogen(or another custom ROM)") I may need to re-partition it anyway. (Honestly I would like to learn how to do all of these, as they would be valuable tools in the future)

I had more questions, but got kinda lost writing this up, I will append them to this post later when I remember them... Thank you in advance for any help you may send my way.


Oh yea, my other issue is accessing the files on the phone under Debian Wheezy. I have tried mtpfs, jmptfs, ptp mode, mtp mode, go-mtpfs (that one somewhat works, I can see *some* of the files, and probably take them off the device, but I attempted to add a file to the SD card and it corrupted the entire card, had to reformat it, just glad I did not do that to the phone)

ADB partially works, but only for taking files off the device, or putting them onto the device in non root areas, I get stuck with "adbd cannot run as root in production builds". I have tried almost everything I can find under the sun in regards to USB access.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes