Remove All Ads from XDA
Honor View 10

Xperia SP problem, please help !

3 posts
Thanks Meter: 0
By Andres1978, Junior Member on 18th April 2014, 02:55 AM
Post Reply Email Thread
Hi, it's my first post, and I need your help.

I have a Sony Xperia SP C5302, untouched Android 4.1.2 (12.0.A.2.254)
Last day I rebooted the device and it didn't turn on, and I haven't installed anything, just normal use. I tried several things and I could turn it on first with the reset hole on the back (10 seconds), then pressing volume down + power, and the device turned on ok. Later I realize the pc (with PC Companion) doesn't recognize the phone. It's the same pc I always use without issues, and with the original cable. Tried on a different pc, but it's the same, luckily I can charge the phone without problem.
Today I made the factory reset, and the only good thing I got is that now I don't need to do the 10 seconds on the back hole, but I must press volume down + power to turn it on, in fact if I just press power (and not volume down), it vibrates but it doesn't turn on, and it won't turn on again unless I do the 10 seconds on the back. The PC still doesn't recognize the phone.

If it helps, phone was rooted and I was using GravityBox for some tweaks, but it was like that for quite a long time, without any issue.

I'd really appreciate your help!
18th April 2014, 07:28 AM |#2  
headache59's Avatar
Senior Member
Thanks Meter: 83
In your position, I would consider this: (back up important data)

Flash full 254 afresh without rooting or recovery.
Test it. If it works, re-root and install whatever you had previously, and enjoy.

If not - send it to sony centre - probably hardware issues...
The Following User Says Thank You to headache59 For This Useful Post: [ View ] Gift headache59 Ad-Free
20th April 2014, 12:14 AM |#3  
OP Junior Member
Thanks Meter: 0
Thank you for your help!
I thought the same, but then I realized there's no USB connection, so I can't flash the phone. Even worst, I have the 266 update pending, so I tried that over wifi, but i don't know with it says there was an error, the update never installs, I tried twice.
It's incredible, I had the phone for 4 months, and just like that, it's broken.

Again, thank you for your time, and if there is anything you think I can try, your welcome!
21st April 2014, 01:53 AM |#4  
Captain Sweatpants's Avatar
Senior Member
Flag Edinburgh
Thanks Meter: 84
I had a similar problem my solution was to factory reset restore all the system apps I had removed basicly make it look like it had never been rooted then use the unroot and cleanup option in superSU and sent it to Sony who replaced it

Programming is a race between engineers striving to build bigger and better idiot-proof programs, and the Universe trying to produce bigger and better idiots. So far, the Universe is winning.
The Following User Says Thank You to Captain Sweatpants For This Useful Post: [ View ] Gift Captain Sweatpants Ad-Free
21st April 2014, 10:56 AM |#5  
niaboc79's Avatar
Recognized Developer / Themer
Flag Enghien
Thanks Meter: 65,217
Donate to Me
Remove all drivers that you have installed related to android on your computer.

Reinstall all of them.

Try to change from MTP to MSC in USB settings to see if your USB port is still working.
The Following User Says Thank You to niaboc79 For This Useful Post: [ View ]
22nd April 2014, 06:19 PM |#6  
OP Junior Member
Thanks Meter: 0
Guys, thank you all for your help, I guess I'll have to live without usb, and forget about flashing. I really liked sony phones
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes