Remove All Ads from XDA
Honor View 10

Hardware Debugging Using Eclipse

22 posts
Thanks Meter: 1
By parthnatu, Junior Member on 23rd April 2014, 07:11 AM
Post Reply Email Thread
I started using ADT to develop new Android applications recently. After a number if tests,I found the emulator to be painfully slow for me. So I decided to use my Razr i to debug it directly. The device is recognized and shows up int the debug list. But when I try to run it, it cannot install the .apk file for my application and says "INVALID APK FILE". I've tried this with various other applications too and it still doesn't work (so I think I can eliminate the possibility of something being wrong with my app itself). Also, I am using Anerik's JellyAOSP ROM. Anybody for a fix?

23rd April 2014, 09:57 AM |#2  
Senior Member
Flag Hamburg, DE
Thanks Meter: 50
Hi, did you use the x86 Android libs? because Ri is x86 hardware... (just my silly idea)
Or didn´t export signed APK? U can make ur own key by File->AndroidTools->Export Signed APK...
Did you allowed "install unsigned Apps" in your Ri Settings?
Maybe some "Manifest" Settings / Permissions? Install Directory: Auto?

I don´t use my Ri to develop, so i never face this problem.
Also be sure to not use 64bit Java or 64bit ADT !!!
I can also test your APK on my Stock RI if u want...

Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes