Remove All Ads from XDA

[Q] LG e975 won't boot, stuck on logo of LG

1 posts
Thanks Meter: 0
By robert1996, Junior Member on 22nd April 2014, 09:26 AM
Post Reply Email Thread
My new phone had been arived a few days ago, i want to install cyanogenmod 11 (kitkat) on my phone, so i installed the nightly buil.d

After that i found a big problem, the phone doesn't detect my sim card (european card), so i have flashed my phone back to stock. That is where the big problem started, the phone won't fully boot anymore. It stucks on te animated LG logo, it doesn't go further.

I tried to solve this by reboot, reflash with original LG software (not a KDZ file as in the first try), but all doesn't work.

The problem still occur.

Can anyone help me to solve this problem?

Your sincereley,

PM: I am sorry for my bad english, it is not the language that my parrents teached me when i grow up......
22nd April 2014, 09:28 AM |#2  
Senior Member
Thanks Meter: 1,238
in fast boot, wipe everything and hard reset. Should solve the issue.
22nd April 2014, 11:43 AM |#3  
Thanks Meter: 8
Originally Posted by akahroba

in fast boot, wipe everything and hard reset. Should solve the issue.

To expand on the above answer in more detail, this type of recovery is covered in the FAQ -

13.Q: I tried custom roms, now I want to go back to stock. How do I do that?
A: Use kdz updater. HERE ( is how to use it. I made simple. Original thread HERE ( IMPORTANT : IF YOU GET STUCK AT LG LOGO AFTER USING KDZ UPDATER,YOU NEED TO PERFORM A HARD RESET. After this,the phone will boot.

Hope this helps
23rd April 2014, 10:44 AM |#4  
puma99dk|'s Avatar
Senior Member
Thanks Meter: 41
this here is very common that ppl don't wipe and hard reset their phones after flashing stock rom comming from a custom rom, even i forgot that the first couple of times
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes