Remove All Ads from XDA
Honor View 10

[Q] Wi-Fi connection "completely dead" - Not connecting to ANY network at all !

44 posts
Thanks Meter: 6
By WatchFan1, Member on 15th April 2014, 06:32 AM
Post Reply Email Thread
I have ATT SM-N900A.
Rooted via Kingo root since day one (back in mid December). Never had any issues.

Everything worked just fine - then I lose W-Fi connectivity 'literally' overnight last week.

I am still running 4.3. There were no software updates or new apps installed when this happened.
In fact, I was on 7 days cruise in the middle of the Caribbean, (data roaming turned off because
the ship was getting expensive 4G service) - when my Wifi abilities completely died. No changes
to the phone that I know of that could have caused this.

I remember checking WiFi on TUE night and the "Royal Caribbean' wifi was available in my stateroom.
At $30 per hour or $60 per day I decided to wait until we get ashore the next day so I could
connect to WiFi in a bar or cafe.
The next morning on WED - once off the ship I tried to turn the WiFi on - no luck. Restarted, shut it off,
took the battery out for a few minutes - still no WiFi the phone does not see and cannot connect
to ANY NETWORKS - None !

Came home from the cruise on Sunday - backed everything up - then performed factory reset
fully expecting to resolve the issue. NOPE Still no Wifi of any kind, cannot see any networks at
all - the wifi icon is never bright green like other active icons - it's only dimmed green as its trying to find
networks, then just goes gray (off)

At this point I am thinking its a hardware issue (dead wifi modem?) - EVERYTHING else on the
phone works just fine (the mini SD card is not corrupted - I also tested the phone without the SD card in the
phone as I found one person who had the same problem and the SD card was the culprit)

Talked to ATT customer service tonight. They suggested I go to their local ATT repair facility or Best Buy
Samsung kiosk to get the 4.4 ATT update and then do another factory reset - to see if that fixes the problem.
If it does not - then they would replace the phone under warranty..

I have some questions:
- 1) any suggestion to fix this (if the 4.4 update does not help....or before I even go to get the 4.4)
- 2) if I unroot via Kingo - will they know that my phone was rooted (and potentially deny the replacement
under warranty which they are now offering if the problem persist). I think that Kingo can unroot just fine, but
does it reset the counter?

Any advice or suggestions how to fix this issue with WIFI or how to present a phone for replacement to ATT that
will qualify - will be greatly appreciated.

Thank you in advance.
15th April 2014, 06:53 AM |#2  
Senior Member
Flag Fayetteville NC
Thanks Meter: 82
There's no "rooting counter". There used to be a ROM Flash counter, but since you can't flash ROMs anyway ... (Safestrap isn't glashing ROMs.)

I'd prefer to not get 4.4, but you can probably restore to MJ5 using the thread here. And I do suspect it's a sudden hardware failure. Software doesn't suddenly break (at least, after 40 years of writing it, that's been my experience). Hardware breaks all the time.

Unrooting via Kingo shouldn't leave anything they'll find. And their tool (in the store) will flash 4.4.2 over 4.3 - but that means no root and, for now, no slots in Safestrap. And if they replace the phone it's probably going to be 4.4.2. (If you go to an AT&T device support center for the replacement, ask really nicely whether they have any refurbs that are still on 4.3 [if that's what you prefer - I have my updater frozen until we get flash and Safestrap on 4.4.2].)
15th April 2014, 07:00 AM |#3  
OP Member
Thanks Meter: 6
Thank you very much for your reply.

I should add that I actually just unrooted via Kingo a few minutes ago.

the "CUSTOM" script with the big lock is now gone from the screen when booting up
and under About Device > Status > Device Status it now reads "Official" instead of "Custom".

How do I check to see if knox counter is tripped ? From what you are saying it looks like I am all set.
Is there anything else I need to do to make sure that they cannot tell that the phone was rooted?

Ultimately, I would still prefer to fix the wifi issue without replacing the phone.
...same as you however - I think that updating to 4.4 wil not resolve anything as i think it is
hardware problem as well.
Thanks for the tip about asking for 4.3 replacement !

what do you mean by:
"I'd prefer to not get 4.4, but you can probably restore to MJ5 "
What is MJ5, and what is slots in Safestrap ?
Thank you !!
15th April 2014, 04:53 PM |#4  
Senior Member
Flag San Diego
Thanks Meter: 24
Donate to Me
I had a similar issue on my Xperia TL and so I thought I would wipe the OS and reinstall it... HARD BRICK'd the phone on a STOCK install via Flashtool. It wasnt like the phone was rooted either.

Turns out it was indeed a physical modem issue. It took me three days to unbrick the phone... I went through torment to get it unbricked. After it was unbricked... I used it for a few days... no good signal at all. Dang wifi and 4G bounced all over the place. I could buy another modem and replace it. AND then I could use the phone again. I said F it ... got a note 3.

On a serious note, you have a hardware prob bro... futz with it if you like... you will make it really non-functional... pull the warranty and get it fixed.
15th April 2014, 09:29 PM |#5  
Senior Member
Flag Fayetteville NC
Thanks Meter: 82
Originally Posted by WatchFan1

How do I check to see if knox counter is tripped ?

Reboot to recovery. (From power off, Volume+/Home/Power.) But I've never heard of Kingo tripping Knox.


Is there anything else I need to do to make sure that they cannot tell that the phone was rooted?

It depends on how thoroughly they check. If they look for deleted files they'll probably find something, but they'll most likely flash 4.4.2 first, and that wipes out any signs of the rooting. (The people at the stores aren't engineers or system programmers, it doesn't work, the book says to flash a new ROM, they do it. It still doesn't work, they replace the phone.)


what do you mean by:
"I'd prefer to not get 4.4, but you can probably restore to MJ5 "
What is MJ5, and what is slots in Safestrap ?

MJ5 is th version of firmware we had before the NB4 update, which is probably what you're on now.

Safestrap is the only way to change ROMs in the Note 3. The bootloader is locked, so you can't just flash a ROM. Safestrap intercepts the boot process and runs the ROM you have in it as the "Current" one. Version 3.71, for 4.3, allows you to have the original ROM plus 4 others in "slots" you set up. So if, for instance, you want to play around with your setup, but be able to get back to what you llike if you mess up, you can back up the current ROM, restore it to a slot and mess around with the one in the slot. Every time you make a change you like, back up again. Make a change you don't like and restore the backup.

Or keep a few ROMS on hand. Maybe one that runs really fast but eats battery like crazy. Another one that's not that fast but you can get almost forever on the battery. Reboot into whichever one you need.

Go to 4.4.2 and Safestrap has, the last time I looked in the thread, only 1 slot. And you can't root 4.4.2 yet. Which is why my wife - who considers it a phone with a few games and a calendar, allowed the update she got the other day, while I have my update app frozen. (Not that it would work with a rooted ROM not in the stock slot, but why ask for problems?)
15th April 2014, 11:11 PM |#6  
OP Member
Thanks Meter: 6
Thanks for the explanation of everything.
I was actually on NB4 already.

Called the local repair ATT center - they do not have any NB3 phones - all replacements are shipped from TX.
To my surprise they did not have the latest 4.4.2 flash and they suggested I go to Best buy !!!! (Unreal !
Went to Best Buy and a fellow in Samsung kiosk had the ATT version of 4.4.2.
We updated the OS, did a factory reset afterwards - the WiFi modem is DEAD as suspected.

Got back to the office, called ATT customer service. They had me download an app and connected to
my phone remotely so they trouble-shoot it. The tech confirmed that the wifi modem is faulty and they
are sending me a replacement phone.
I tried to request 4.3 and he said that it could be 4.3 or 4.4 (depending how long it has been sitting on the
shelf in their warehouse - but the selection is random and there is no way to request a specific OS version.
Good news is that I do not have to be without a phone and will simply return my old phone in the same box.
16th April 2014, 09:58 PM |#7  
Senior Member
Flag Fayetteville NC
Thanks Meter: 82
At least you'll get wifi. Keep your fingers crossed that you get an "old phone". Or that the work on SS doesn't take too long.
17th April 2014, 12:41 AM |#8  
Senior Member
Flag Garden City
Thanks Meter: 29
Funny enough, I had almost the same thing happen. Went on vacation overseas and turned everything off. Used Wifi sporadically and when I returned home, I had no wifi. Warranty exchange gave me a replacement phone and shortly after that it automatically upgraded to 4.4.2. I actually started a thread but no one had had the same issue as me. Good luck with your new phone.
23rd April 2014, 04:44 PM |#9  
OP Member
Thanks Meter: 6
Thumbs up
Great news !
My replacement phone arrived yesterday and to my pleasant surprise it is 4.3.
Its actually MJ5 (the original?) baseband - not NB4.
Kernel is from Thu Oct. 17th 2013.
I guess I can just leave it 'as is' correct?

In a meanwhile that baby got rooted on Kingo immediately and the "AT&T update app"
was frozen with Titanium backup really quickly

Thanks everyone for your comments and suggestions.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes