Remove All Ads from XDA

[Q] Unable to install GApps on Maxell C8 with ICS

4 posts
Thanks Meter: 0
By czdraconis, Junior Member on 10th April 2014, 01:01 PM
Post Reply Email Thread
Hi all,

I'd like to politely ask for your help with adding Google Play to my friend's tablet which unfortunately doesn't provide this app in factory setting.

First of all I'd like to mention that I've searched here before (and other sources over the internet as well) and found many threads with similar issues. Still I was unable to get everything working because of some problems that I'm not able to solve as I'm still just a user... Unfortunately it seems that each device is unique and requires a little different stuff to reach the goal.

So here's some basic information about the device:
  • Maxell Maxtab C8
  • Android 4.0.4
  • Kernel version: 3.0.8+
Here's what I was able to do so far:
  • Successfully rooted the device
  • Successfully set -rw to /system (using the "Mount /system (-rw / -ro)" app
I've tried many various Google Play installers including:
  1. Android
  2. PlayStore_v4.6.17.apk found somewhere here in the forums
And about 5 more other without any success. Result is that Google Play is there but it doesn't work - I mean the icon has been added, Gmail account has been "assigned" to it during its first run and then every time I try to run Google Play there occurs an error saying that "Google Play stopped working" and it simply won't run. I also tried the simple solution with "Android-Market_install_files" package (4 apps) - as I found out it's the official way how to use Google Play on devices where it's not preinstalled. Still it didn't work as well - again ended up with the same error (stopped working). But there is maybe some kind of problem with the installation because two of four .apk files included in the "Android" package cannot be installed as the device tells me that this app cannot be installed because of the conflicting signature (I found more about this here: I'm using files signed by Google. Advices are to firstly uninstall the original apps and then install these but I'm not able to uninstall as I can't find them. Guess these are some kind of system apps and I'm not sure where to find them exactly. Still no luck even using Root Explorer. These apps are called "OneTimeInitializer-signed.apk" and "GoogleServicesFramework-signed.apk". I think maybe Google Play from this package could work but the problem is caused by the device which doesn't overwrite the original apps (because of the signature).

Currently I've also found GApps Manager ( - I think this might work but I'm not able to test it at all. Simply I can't find how to get this Maxell tablet into recovery mode to find the "install from zip file" option.

Interesting is that there is no "Phonesky.apk" file in the device's memory...

Sorry for my post being soooo long but I'd like to provide as many additional information as possible.

Could you please give me advice how to install GApps on Maxell Maxtab C8 device or any other solution?

This could look easy for many of you but I'm working on it over two weeks now and I'm really clueless, even more when there are users confirming that Google Play works with this device. So I hope you're be so glad to help. Any help will be highly appreciated! Thanks!

With kind regards

10th April 2014, 03:19 PM |#2  
TheArc's Avatar
Recognized Themer
Flag Auckland City
Thanks Meter: 2,094
Donate to Me
Some info, since you have root, you can simply move .apk to your /system/app folder.

Also you had stated there is a conflicting issue with the same type of signature, this is because there is already an existing file of the same source.

To uninstall this .apk it usually located in the following folder(s).

- /system/app
- /system/priv-app

Just select and delete it. Reboot the device. And move your new files into /system/app and reboot. Make sure you also move Ann app called "Google Play Services.apk or GP will not start

Great things come in small packages.
12th April 2014, 11:04 AM |#3  
OP Junior Member
Thanks Meter: 0
Hi krishneelg3,

many thanks for your answer. Your advice looked really easy and reasonable but it didn't work.

I deleted all required .apk files from /system/app. Maxell tablet doesn't have /system/priv-app folder. Then I copied all the GApps files to corresponding folders in the tablet (/system/app, /system/etc, /system/framework, /system/lib). Then the setup wizard started but when I tried to confirm the setup guide touching the green Android icon it did nothing. After restarting the tablet I didn't see the setup wizard app any more. Tried about 5 times in a row from the beginning (copied the original files from the backup back to tablet, then replace them with the new ones from GApps) and always ended up with the same result.

There's also META-INF folder included in the GApps package. It seems to contain some certificates but I'm not sure what to do with it or where to copy these files. Could this be causing the problem?

Thank you very much.

12th April 2014, 11:10 AM |#4  
TheArc's Avatar
Recognized Themer
Flag Auckland City
Thanks Meter: 2,094
Donate to Me
I would like to tell you that, the GApps package is supposed to flashed via recovery.

The META INFO contains scripts to install and also certs

So if you have a custom recovery available for your device flash the custom recovery img and if you already have it then just flash it via recovery.
24th April 2014, 12:21 PM |#5  
OP Junior Member
Thanks Meter: 0
Sorry for the delay... I didn't manage how to switch the device to recovery mode. I tried many solutions reported to work for this device but they didn't for me. Some tested, some not because apparently my knowledge is user-level. To be honest after over 3 weeks trying I gave up.

But thanks for your effort.

Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes