Remove All Ads from XDA
Honor 9 Lite

signapk problem on large archives

916 posts
Thanks Meter: 856
By annson08, Senior Member on 26th April 2014, 04:54 PM
Post Reply Email Thread
Good day everyone. I really need help on this matter.

I'm currently in the proccess of repacking a stock rom for our device, however, I can't sign the archive.

here's the command i use.

signapk.jar -w testkey.x509.pem testkey.pk8 "" ""
that code I'm using works on smaller archive around 10MB or less, but using it in an entire rom ranging from 100MB to 300MB gives me bunch of problems.

One is, the command isn't giving the output archive, the file.

Second is, when i remove the -w in the command, the will be generated but when i flash it on the recovery, it always give the signature verification error.

Here's more info to help anyone who's willing to answer to my problem. I tried different signer to sign my rom, (ofcourse I use my keys that should work) but it still gives me the error when flashing, I even tried to use android kitchen to sign it but still no luck. I also tried to sign my smaller archive I've mentoned above to other signer (just to test it) and it gave me the signature verification error too. It seems I can only sign my archives the old fashion way, through cmd.

Please help. Thanks.

PS. I use windows.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes