Remove All Ads from XDA

[Q] HTC One won't connect to data network after installing custom ROM(s)

3 posts
Thanks Meter: 1
By Tazkaza, Junior Member on 27th April 2014, 07:18 AM
Post Reply Email Thread
Hi guys!

So I've been a lurker on here for forever (since my Touch Pro actually...whoa), but haven't participated much before now. Either way, I don't think I'm too much of a noob. However, today I took the plunge and rooted my One. I haven't messed around with this stuff since my Evo 4G so I tried to follow directions and do everything right. I then went to install a custom ROM (really a series of ROMs because of this mess), and everything seems to work well enough. However, when I got to set up my phone, the setup process hung on "Activate mobile data service" before telling me it couldn't connect. I figured it was just an error with the nightly I was using so I switched to another ROM and the same thing happened.

In this order, I've tried
  1. Pac ROM
  2. Liquid
  3. Beanstalk
  4. CM11
and have had the same issue every time. Clean flash and everything. I figured maybe it was an issue with CM based ROMs, but twrp fails every time I try to install AOKP and I haven't seen a real, current fix for this issue (tried changing APN), nor many people talking about any problems over the past few months.

Anybody that can help, I GREATLY appreciate it! I seriously don't know where to look now. I feel like I've searched everywhere but no luck.

EDIT: Additionally, I just tried to flash SlimKat. When it got to the "Activate mobile data service" it dialed a number which replied with "The feature code you have entered is not valid" .....WHAT?
27th April 2014, 07:13 PM |#2  
Junior Member
Thanks Meter: 0
I'm having a similar issue on my G2. I wasn't flashing ROMs, but was using an Xposed module. Wifi works, but mobile data does not. I just made a thread about this myself.
Post Reply Subscribe to Thread

cm11, data connection, htc one, m7spr, sprint

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes