Remove All Ads from XDA
Honor 9 Lite

[Q] i9500 RomSwitcher - Update broke it

5 posts
Thanks Meter: 1
By dagelf, Junior Member on 28th April 2014, 11:59 AM
Post Reply Email Thread
Hi, RomSwitcher has been nagging me to update since I installed it. So finally, I clicked Update.

Now my phone doesn't show the boot logo, it just boots into a blank screen. Adb seems to function:

C:\Unified_Android_ToolKit>adb shell
- exec '/system/bin/sh' failed: No such file or directory (2) -

Anyways, if I ODIN any Perseus kernel, then my first ROM boots fine. But if I go into RomSwitcher and install the tools, then reboot boots into blackness again. I've tried to install the tools from the recovery, same thing happens.

I would post this in the Development thread, but I'm not allowed to post there yet. So as I understand it, RomSwitcher boots into it's own environment, changes some directories so one of several ROMS will boot. What seems to happen is that the RomSwitcher environment is just blank. I have no idea where to look, and I can't find the old version of RomSwitcher which worked anymore. I don't really want to reflash everything just to get RomSwitcher functionality back.

There's no information on the internet about how it works or how to fix it. It seems I've probably managed to wipe the configuration when updating it. If anyone can point me to a FAQ or Guide or something about how it works, or summarise it, I'll really appreciate it, as I don't really want to go and dig through the code to figure it out... that might take me several weeks with the little time I have available!

What is in the configuration file?
Where is it stored?
Can I re-create it by hand?
What's the simplest way to get RomSwitcher working again, without starting from scratch with all my ROMs?
(I'm just dual booting Phoenix ROM and CM11, which worked fine until I updated RomSwitcher. New RomSwitcher looks good, but doesn't work!)

28th April 2014, 12:13 PM |#2  
OP Junior Member
Flag Stellenbosch
Thanks Meter: 1
Steps to repeat...
So, I've tried every Perseus kernel: 16, 18, 19

From the main TW based ROM that boots: Phoenix 10.1

RomSwitcher says to install Tools and Reboot before it does anything. Doing that reboots into a black screen, no matter what kernel. I've re-downloaded the main config and the tools several times.

Seems the only thing left to try is re-flash main ROM, re-install RomSwitcher... then it will probably work But that is a 3-4 hour operation I can't afford right now.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes