Remove All Ads from XDA

[Q] CM11 - 64GB SD card troubles (missing folders)

868 posts
Thanks Meter: 123
By mvmacd, Senior Member on 28th April 2014, 07:26 PM
Post Reply Email Thread
I have a galaxy S4 Sprint, and I just bought a Sony 64GB class 10 card from Amazon. I formatted it with SD Formatter (exFAT) with the program from

I copied all my files over, and I had about 3GB of photos in DCIM/Camera/. Then today I tried to view my gallery but the photos didn't show up. I checked in a file manager /storage/sdcard1/DCIM/Camera/ and it said 0 files. I thought "Great, it lost the whole folder, now I'll have to copy it from my old card"

So I put in my new card into my SD card reader [microSD to SD adapter, into laptop SD slot], and I navigate to DCIM/Camera/, and on my computer, it shows 3GB worth of files in there! So I move it back to my phone, and it shows 0 files. I am 100% sure I'm in the right directory since I made a blank file in DCIM/ and it shows up on both laptop and phone.

another thing, when I try to put anything in DCIM/Camera/ it fails (file manager gives error, but terminal command "touch test-file.txt" doesn't give error, but "ls" shows no files there)

I am running the latest CM11 snapshot M3 for jfltespr [Sprint GS4]. I'm quite baffled by this. Can anybody suggest something to fix this issue? I was thinking of formatting my card to ext4, but windows doesn't support it natively [I have Linux dual boot though].

Update: since nobody suggested anything, I renamed Camera to Camera2, then created a new directory, Camera, then cut/paste all pics in Camera2 into Camera, and now I have everything back in my gallery..
Also I tried running chkdsk on the sd card, but it found no errors. I ran it twice. Anyway, not sure what happened, but hopefully it doesn't happen again.
Post Reply Subscribe to Thread

exfat, sdcard

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes