Remove All Ads from XDA
Honor 9 Lite

Not charging as quickly as used to since Cyanogenmod 11 Nightly flash

13 posts
Thanks Meter: 2
By WeActOnImpulse, Junior Member on 27th April 2014, 04:22 AM
Post Reply Email Thread
Not sure if I am supposed to (allowed to?) ask for help or troubleshooting on Nightlies. ^_^' So sorry if I am doing something wrong. I'm fairly new and have only really helped a couple of people fix stuff here on XDA.
I have an LG Optimus G pro e980 running cm-11-20140425-NIGHTLY which is Android 4.4.2 KitKat. When I flashed it I factory reset, cleared cache, cleared dalvik cache, and flashed the ROM and flashed Gapps. When the ROM booted up I didn't do a second factory reset, don't know if this is bad. Here is the tutorial I followed. I still have excellent battery life, it just doesn't charge as quickly as it used to. I think the battery life is actually better with Cyanogen.
I was having terrible battery life but it was because I had setCPU holding the CPU at 1.7ghz constantly, and CleanMaster wouldn't allow the phone to deep sleep. I can deep sleep now and have resolved all battery drainage issues.
Here's screens of CPU (images weren't showing for me so these are the links)
That is after 23 hours uptime.

On stock ROM I could 100% the phone in 45 minutes to an hour from like 20-30% range. it would take only a few minutes when I was around 85%. It charged ridiculously fast and I loved it. Now on Cyanogenmod it takes 6-8+ hours to charge. I find myself tied to a charger all day now. Sometimes when I put it on the charger at night and wake up it'll only be at like 94%. I did some research and I think it might be the kernel changing the voltage regulator's amperage limit. I don't know if this is the issue, or how to go about fixing it. I haven't flashed a kernel myself (at least I don't think so). Kernels are new to me. Perhaps there is an app to change the voltage regulator's setting, or a different kernel? or maybe it's just a problem with the Nightly and it will be resolved eventually? Seriously this is almost enough to make me go to the stock ROM again, lolxd.

Also, I get the message every few minutes "Unfortunately, Google+ has stopped responding". Could be this be because I didn't do the second factory reset?
Thanks, the best.
27th April 2014, 05:22 AM |#2  
stulzerl's Avatar
Senior Member
Flag Tampa, Florida
Thanks Meter: 39
Bad flash? Have you tried a clean install?

Sent from my LG-E980 using XDA Premium 4 mobile app
The Following User Says Thank You to stulzerl For This Useful Post: [ View ] Gift stulzerl Ad-Free
28th April 2014, 09:07 AM |#3  
OP Junior Member
Thanks Meter: 2
Donate to Me
Originally Posted by stulzerl

Bad flash? Have you tried a clean install?

Sent from my LG-E980 using XDA Premium 4 mobile app

I did a clean install and it is still charging much slower than it was on the stock ROM. The "Unfortunately, Google+ has stopped" error is gone though. That's good. ^_^ Think it's just because KitKat draws in too many system resources? Then again my battery life is still great as far as I can tell... Hmm...
1st May 2014, 08:01 AM |#4  
OP Junior Member
Thanks Meter: 2
Donate to Me
Thought I would update on this. It's working now.
Thanks for the advice on flashing again as that solved a lot of problems i was having.
It seems to have sorted itself out over time, though. It's charging just as quickly as ever now. (If not faster than ever). It probably just needed a few charge/discharge cycles for the new ROM to adjust to the battery capacity. Thanks for the help, though. ^^
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes