Remove All Ads from XDA

Play store connectivity error following root

6 posts
Thanks Meter: 0
By UnfriendlyTurtle, Junior Member on 3rd May 2014, 01:19 PM
Post Reply Email Thread
So I rooted my tablet and everything is working fine, but soon after I'm getting errors with the Play store ("No connection" + retry button) and with signing into a Google account ("Can't establish reliable connection to server"). Otherwise, it's doing fine; social media, YouTube and browsing are all working at decent speeds and I'm posting from the tablet. Also, the wifi signal in the drop down menu appears orange, which to my understanding denotes limited access, but my PC doesn't return the same error.

I've tried deleting the cache and data of the play store, rebooting, switching aeroplane mode on and off, reconnecting after forgetting the network - nothing.

It was fine immediately after rooting with the Nexus Root Toolkit, but started playing up soon after I installed and launched App Ops X. Disabling that hasn't worked either.

I also changed the time zone up a bit earlier, but put it back to automatic.

Thanks in advance.

Edit: the indicator is still orange, but I managed to get the Play store and Google services up and running by adding another server to the host file in /etc, although downloads are painfully slower. Can anyone explain why this worked and it didn't before, because I already had one there with a different IP. Also, are there any faster domains for me to add? Thanks.
Post Reply Subscribe to Thread

Guest Quick Reply (no urls or BBcode)
Previous Thread Next Thread
Thread Tools Search this Thread
Search this Thread:

Advanced Search
Display Modes